summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMikko Orispaa <mikko.orispaa@gmail.com>2015-11-20 07:32:34 +0000
committerMikko Orispaa <mikko.orispaa@gmail.com>2015-11-20 07:32:34 +0000
commit42546982a254031a5ead53e53ba2a5872b582651 (patch)
tree22c15ca5194fdbc49b22d0bd6ad93787b3c61f6c /CMakeLists.txt
parent031d73b0a86058c4a7cb0ecebd7fb2a9015cf13b (diff)
downloadffts-42546982a254031a5ead53e53ba2a5872b582651.zip
ffts-42546982a254031a5ead53e53ba2a5872b582651.tar.gz
Changed NEON test in CMakeList.txt so that it works for newer ARMs (-mfloat-abi=hard). Fixed a bug in test.c (did not compile for NEON-ARM).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 00122db..f6f5c4c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -130,7 +130,7 @@ if(NOT CMAKE_CROSSCOMPILING)
)
# Test running with -mfpu=neon
- set(CMAKE_REQUIRED_FLAGS "${CMAKE_REQUIRED_FLAGS_SAVE} -mfpu=neon -mfloat-abi=softfp")
+ set(CMAKE_REQUIRED_FLAGS "${CMAKE_REQUIRED_FLAGS_SAVE} -mfpu=neon -mfloat-abi=hard")
check_c_source_runs("${TEST_SOURCE_CODE}" NEON_SUPPORTED)
if(NOT NEON_SUPPORTED)
@@ -389,4 +389,4 @@ add_executable(ffts_test
target_link_libraries(ffts_test
ffts_static
${FFTS_EXTRA_LIBRARIES}
-) \ No newline at end of file
+)
OpenPOWER on IntegriCloud