summaryrefslogtreecommitdiffstats
path: root/common/recipes-utils/jbi/jbi_2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-utils/jbi/jbi_2.2.bb')
-rw-r--r--common/recipes-utils/jbi/jbi_2.2.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/common/recipes-utils/jbi/jbi_2.2.bb b/common/recipes-utils/jbi/jbi_2.2.bb
new file mode 100644
index 0000000..947dbac
--- /dev/null
+++ b/common/recipes-utils/jbi/jbi_2.2.bb
@@ -0,0 +1,41 @@
+# Copyright 2015-present Facebook. All Rights Reserved.
+#
+# This program file is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the
+# Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program in a file named COPYING; if not, write to the
+# Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301 USA
+
+SUMMARY = "ALTERA Jam STAPL Byte-Code Player"
+SECTION = "utils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
+
+SRC_URI = "file://code \
+ "
+
+S = "${WORKDIR}/code"
+
+DEPENDS += "liblog libgpio"
+
+do_install() {
+ bin="${D}/usr/local/bin"
+ install -d ${bin}
+ install -m 755 jbi ${bin}/jbi
+}
+
+FILES_${PN} = "/usr/local/bin"
+
+FILES_${PN}-dbg += "/usr/local/bin/.debug"
+
+INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
+INHIBIT_PACKAGE_STRIP = "1"
OpenPOWER on IntegriCloud