summaryrefslogtreecommitdiffstats
path: root/common/recipes-utils/jbi/jbi_2.2.bb
diff options
context:
space:
mode:
authorOri Bernstein <orib@fb.com>2015-09-03 13:06:18 -0700
committerOri Bernstein <orib@fb.com>2015-09-23 18:10:45 -0700
commit67f44805b41a532b7b440773f7ee6d17dc0e97f4 (patch)
treec21a66b12c4d92a765e1ee0d47b96e2a2b9cd0d2 /common/recipes-utils/jbi/jbi_2.2.bb
parent2a51b7c1c2165ddb188c511e192b75f0aa0fbead (diff)
downloadast2050-yocto-openbmc-67f44805b41a532b7b440773f7ee6d17dc0e97f4.zip
ast2050-yocto-openbmc-67f44805b41a532b7b440773f7ee6d17dc0e97f4.tar.gz
Openbmc dev snapshot.
Diffstat (limited to 'common/recipes-utils/jbi/jbi_2.2.bb')
-rw-r--r--common/recipes-utils/jbi/jbi_2.2.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/common/recipes-utils/jbi/jbi_2.2.bb b/common/recipes-utils/jbi/jbi_2.2.bb
new file mode 100644
index 0000000..947dbac
--- /dev/null
+++ b/common/recipes-utils/jbi/jbi_2.2.bb
@@ -0,0 +1,41 @@
+# Copyright 2015-present Facebook. All Rights Reserved.
+#
+# This program file is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the
+# Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program in a file named COPYING; if not, write to the
+# Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301 USA
+
+SUMMARY = "ALTERA Jam STAPL Byte-Code Player"
+SECTION = "utils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
+
+SRC_URI = "file://code \
+ "
+
+S = "${WORKDIR}/code"
+
+DEPENDS += "liblog libgpio"
+
+do_install() {
+ bin="${D}/usr/local/bin"
+ install -d ${bin}
+ install -m 755 jbi ${bin}/jbi
+}
+
+FILES_${PN} = "/usr/local/bin"
+
+FILES_${PN}-dbg += "/usr/local/bin/.debug"
+
+INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
+INHIBIT_PACKAGE_STRIP = "1"
OpenPOWER on IntegriCloud