summaryrefslogtreecommitdiffstats
path: root/meta-raptor/meta-asus/recipes-kernel/i2c-dev-sysfs-mod/files/Makefile
diff options
context:
space:
mode:
authorTimothy Pearson <tpearson@raptorengineering.com>2017-08-27 16:20:38 -0500
committerTimothy Pearson <tpearson@raptorengineering.com>2017-08-27 16:20:38 -0500
commit84eea7fdc46dd76e84cafbf96813bc826d5e08ad (patch)
tree035d28afe18ce33231b956349d1a3a90ec763d60 /meta-raptor/meta-asus/recipes-kernel/i2c-dev-sysfs-mod/files/Makefile
parente65a7944211c70f6b5cfb6cedd73cc31105319de (diff)
downloadast2050-yocto-openbmc-84eea7fdc46dd76e84cafbf96813bc826d5e08ad.zip
ast2050-yocto-openbmc-84eea7fdc46dd76e84cafbf96813bc826d5e08ad.tar.gz
Add initial support for the ASpeed 2050 and the ASUS KGPE-D16
Thermal management is functional but expects all fans to be attached Known issues: * BMC has been observed spontaneously rebooting after ~7-8 hours uptime with no logs and no console output. * While kcs has been implemented, the IPMI daemon is only functional enough to report chassis status.
Diffstat (limited to 'meta-raptor/meta-asus/recipes-kernel/i2c-dev-sysfs-mod/files/Makefile')
-rw-r--r--meta-raptor/meta-asus/recipes-kernel/i2c-dev-sysfs-mod/files/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-raptor/meta-asus/recipes-kernel/i2c-dev-sysfs-mod/files/Makefile b/meta-raptor/meta-asus/recipes-kernel/i2c-dev-sysfs-mod/files/Makefile
new file mode 100644
index 0000000..4be7b62
--- /dev/null
+++ b/meta-raptor/meta-asus/recipes-kernel/i2c-dev-sysfs-mod/files/Makefile
@@ -0,0 +1,31 @@
+# Copyright 2015-present Facebook. All Rights Reserved.
+#
+# This program file is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the
+# Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program in a file named COPYING; if not, write to the
+# Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301 USA
+
+obj-m := i2c_dev_sysfs.o
+
+SRC := $(shell pwd)
+
+all:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC)
+
+modules_install:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules_install
+
+clean:
+ rm -f *.o *~ core .depend .*.cmd *.ko *.mod.c
+ rm -f Module.markers Module.symvers modules.order
+ rm -rf .tmp_versions Modules.symvers
OpenPOWER on IntegriCloud