summaryrefslogtreecommitdiffstats
path: root/meta-raptor/meta-asus/recipes-core/busybox
diff options
context:
space:
mode:
authorTimothy Pearson <tpearson@raptorengineering.com>2017-08-27 16:20:38 -0500
committerTimothy Pearson <tpearson@raptorengineering.com>2017-08-27 16:20:38 -0500
commit84eea7fdc46dd76e84cafbf96813bc826d5e08ad (patch)
tree035d28afe18ce33231b956349d1a3a90ec763d60 /meta-raptor/meta-asus/recipes-core/busybox
parente65a7944211c70f6b5cfb6cedd73cc31105319de (diff)
downloadast2050-yocto-openbmc-84eea7fdc46dd76e84cafbf96813bc826d5e08ad.zip
ast2050-yocto-openbmc-84eea7fdc46dd76e84cafbf96813bc826d5e08ad.tar.gz
Add initial support for the ASpeed 2050 and the ASUS KGPE-D16
Thermal management is functional but expects all fans to be attached Known issues: * BMC has been observed spontaneously rebooting after ~7-8 hours uptime with no logs and no console output. * While kcs has been implemented, the IPMI daemon is only functional enough to report chassis status.
Diffstat (limited to 'meta-raptor/meta-asus/recipes-core/busybox')
-rw-r--r--meta-raptor/meta-asus/recipes-core/busybox/busybox/busybox.cfg18
-rw-r--r--meta-raptor/meta-asus/recipes-core/busybox/busybox/syslog-startup.conf13
-rw-r--r--meta-raptor/meta-asus/recipes-core/busybox/busybox/syslog.conf5
-rw-r--r--meta-raptor/meta-asus/recipes-core/busybox/busybox_%.bbappend7
4 files changed, 43 insertions, 0 deletions
diff --git a/meta-raptor/meta-asus/recipes-core/busybox/busybox/busybox.cfg b/meta-raptor/meta-asus/recipes-core/busybox/busybox/busybox.cfg
new file mode 100644
index 0000000..66da117
--- /dev/null
+++ b/meta-raptor/meta-asus/recipes-core/busybox/busybox/busybox.cfg
@@ -0,0 +1,18 @@
+CONFIG_SH_MATH_SUPPORT_64=y
+CONFIG_DEVMEM=y
+CONFIG_LSUSB=y
+CONFIG_FEATURE_PS_ADDITIONAL_COLUMNS=y
+CONFIG_RX=y
+CONFIG_FLASHCP=y
+CONFIG_FLASH_LOCK=y
+CONFIG_FLASH_UNLOCK=y
+CONFIG_FLASH_ERASEALL=y
+CONFIG_TRACEROUTE6=y
+CONFIG_VCONFIG=y
+# we use the standalone ip util
+CONFIG_IP=n
+# use dhclient, as udhcpc will flush all v6 link local addresses during renew
+CONFIG_FEATURE_IFUPDOWN_EXTERNAL_DHCP=y
+CONFIG_UDHCPD=n
+CONFIG_UDHCPC=n
+CONFIG_UDHCPC6=n
diff --git a/meta-raptor/meta-asus/recipes-core/busybox/busybox/syslog-startup.conf b/meta-raptor/meta-asus/recipes-core/busybox/busybox/syslog-startup.conf
new file mode 100644
index 0000000..53d7297
--- /dev/null
+++ b/meta-raptor/meta-asus/recipes-core/busybox/busybox/syslog-startup.conf
@@ -0,0 +1,13 @@
+# This configuration file is used by the busybox syslog init script,
+# /etc/init.d/syslog[.busybox] to set syslog configuration at start time.
+
+DESTINATION=file # log destinations (buffer file remote)
+LOGFILE=/var/log/messages # where to log (file)
+REMOTE=loghost:514 # where to log (syslog remote)
+REDUCE=no # reduce-size logging
+DROPDUPLICATES=no # whether to drop duplicate log entries
+ROTATESIZE=128 # rotate log if grown beyond X [kByte]
+ROTATEGENS=1 # keep X generations of rotated logs
+BUFFERSIZE=64 # size of circular buffer [kByte]
+FOREGROUND=no # run in foreground (don't use!)
+#LOGLEVEL=5 # local log level (between 1 and 8)
diff --git a/meta-raptor/meta-asus/recipes-core/busybox/busybox/syslog.conf b/meta-raptor/meta-asus/recipes-core/busybox/busybox/syslog.conf
new file mode 100644
index 0000000..817a9a9
--- /dev/null
+++ b/meta-raptor/meta-asus/recipes-core/busybox/busybox/syslog.conf
@@ -0,0 +1,5 @@
+# /etc/syslog.conf Configuration file for busybox's syslogd utility
+# Send emergency messages to the console
+*.emerg /dev/console
+# Store everything else
+*.* /var/log/messages
diff --git a/meta-raptor/meta-asus/recipes-core/busybox/busybox_%.bbappend b/meta-raptor/meta-asus/recipes-core/busybox/busybox_%.bbappend
new file mode 100644
index 0000000..501d2a1
--- /dev/null
+++ b/meta-raptor/meta-asus/recipes-core/busybox/busybox_%.bbappend
@@ -0,0 +1,7 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += " \
+ file://busybox.cfg \
+ file://syslog.conf \
+ file://syslog-startup.conf \
+ "
OpenPOWER on IntegriCloud