summaryrefslogtreecommitdiffstats
path: root/sys/arm/altera/socfpga/socfpga_mp.c
Commit message (Collapse)AuthorAgeFilesLines
* MFC r306756:mmel2016-10-151-1/+2
| | | | | ARM: SEV/WFE instructions are implemented starting from ARMv6K, use it directly.
* Almost all copies of platform_mp_init_secondary just calledandrew2016-02-261-7/+0
| | | | | | | | | intr_pic_init_secondary. Replace them with a direct call. On BCM2836 and ARMADA XP we need to add this function, but it can be empty. Reviewed by: ian, imp Sponsored by: ABT Systems Ltd Differential Revision: https://reviews.freebsd.org/D5460
* Remove platform_mp_probe as it's almost identical on most ARM SoCs, andandrew2016-02-261-10/+0
| | | | | | | | | | slightly wrong on the others. We should just check if mp_ncpus is set to more than one CPU as we may wish to run on a single core even when SMP is available. Reviewed by: ian Sponsored by: ABT Systems Ltd Differential Revision: https://reviews.freebsd.org/D5458
* Remove platform_ipi_send, it's an unneeded as all implementations areandrew2016-02-251-7/+0
| | | | | | identical. Sponsored by: ABT Systems Ltd
* ARM: Use new ARMv6 naming conventions for cache and TLB functionsmmel2016-02-051-2/+2
| | | | | | in all but ARMv4 specific files. Expand ARMv6 compatibility stubs in cpu-v4.h. Use physical address in L2 cache functions if ARM_L2_PIPT is defined.
* [intrng] Migrate the intrng code from sys/arm/arm to sys/kern/subr_intr.c.adrian2015-12-181-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | The ci20 port (by kan@) is going to reuse almost all of the intrng code since the SoC in question looks suspiciously like someone took an ARM SoC design and replaced the ARM core with a MIPS core. * migrate out the code; * rename ARM_ -> INTR_; * rename arm_ -> intr_; * move the interrupt flush routine from intr.c / intrng.c into arm/machdep_intr.c - removing the code duplication and removing the ARM specific bits from here. Thanks to the Star Wars: The Force Awakens premiere line for allowing me a couple hours of quiet time to finish the universe builds. Tested: * make universe TODO: * The structure definitions in subr_intr.c still includes machine/intr.h which requires one duplicates all of the intrng definitions in the platform code (which kan has done, and I think we don't have to.) Instead I should break out the generic things (function declarations, common intr structures, etc) into a separate header. * Kan has requested I make the PIC based IPI stuff optional.
* Rename arm_init_secondary_ic() -> arm_pic_init_secondary(). The latter isian2015-10-181-1/+1
| | | | | | the name the function will have when the new ARM_INTRNG code is integrated, and doing this rename first will make it easier to toggle the new interrupt handling code on/off with a config option for debugging.
* Include vm/pmap.h for pmap_kextract.andrew2015-04-041-0/+3
|
* Rename gic_init_secondary to arm_init_secondary_ic to help with the mergeandrew2015-01-111-1/+1
| | | | of the arm_intrng project branch.
* o Add machine-dependent SMP partbr2014-10-101-0/+180
o Enable SMP Sponsored by: DARPA, AFRL
OpenPOWER on IntegriCloud