summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorpsychocrypt <psychocrypt@users.noreply.github.com>2017-10-20 21:17:08 +0200
committerpsychocrypt <psychocrypt@users.noreply.github.com>2017-10-20 21:17:08 +0200
commitd7209b21fd5f388728c2fe40c92fcc4900d096e3 (patch)
tree581045c9001335206e1b1aa481a7c4649fa5f2c2 /CMakeLists.txt
parent6701b0c2025987674708c9984c1d76461428c09e (diff)
downloadxmr-stak-d7209b21fd5f388728c2fe40c92fcc4900d096e3.zip
xmr-stak-d7209b21fd5f388728c2fe40c92fcc4900d096e3.tar.gz
add NVIDIA Volta support
add `sm_70` if CUDA 9+ is avalable
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 015f7c2..9ae7b26 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -79,6 +79,10 @@ if(CUDA_ENABLE)
if(NOT CUDA_VERSION VERSION_LESS 8.0)
list(APPEND DEFAULT_CUDA_ARCH "60" "61" "62")
endif()
+ # add Volta support for CUDA >= 9.0
+ if(NOT CUDA_VERSION VERSION_LESS 9.0)
+ list(APPEND DEFAULT_CUDA_ARCH "70")
+ endif()
set(CUDA_ARCH "${DEFAULT_CUDA_ARCH}" CACHE STRING "Set GPU architecture (semicolon separated list, e.g. '-DCUDA_ARCH=20;35;60')")
# validate architectures (only numbers are allowed)
OpenPOWER on IntegriCloud