summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDerek Adams <juugcatm@users.noreply.github.com>2017-12-14 23:20:25 -0800
committerGitHub <noreply@github.com>2017-12-14 23:20:25 -0800
commit73de502585efb04686d330cddcfcb91644a7fac0 (patch)
treec82f676f4f3a7d1f6bf2edb8d6a1d296f536e85f /CMakeLists.txt
parent31a078416042d5492540f4bdb1466a84b690430e (diff)
downloadxmr-stak-73de502585efb04686d330cddcfcb91644a7fac0.zip
xmr-stak-73de502585efb04686d330cddcfcb91644a7fac0.tar.gz
Update CMakeLists.txt
Installed xmr-stak on fresh Ubuntu 16.04 with just AMDGPU-PRO and required these changes and use of OpenCL_ROOT=/opt/amdgpu-pro for successful compilation with OpenCL. Also requires the opencl-headers package from Ubuntu's repository.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b8f1eef..0d70268 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -228,6 +228,7 @@ if(OpenCL_ENABLE)
ENV AMDAPPSDKROOT
ENV ATISTREAMSDKROOT
ENV "PROGRAMFILES(X86)"
+ /usr/include
PATH_SUFFIXES
include
OpenCL/common/inc
@@ -246,6 +247,7 @@ if(OpenCL_ENABLE)
PATH_SUFFIXES
"AMD APP/lib/x86_64"
lib/x86_64
+ lib/x86_64-linux-gnu
lib/x64
OpenCL/common/lib/x64)
# find package will use the previews searched path variables
OpenPOWER on IntegriCloud