summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorpsychocrypt <psychocrypt@users.noreply.github.com>2017-10-31 21:31:15 +0100
committerpsychocrypt <psychocrypt@users.noreply.github.com>2017-10-31 21:36:00 +0100
commit59a1531649fe0a8de38191771d0b12decfdea072 (patch)
tree669cd48581a1bffde6aa6b6f0adf252ca00df504 /CMakeLists.txt
parent69e6013cee02299e4732b02a83025e7011b12f5e (diff)
downloadxmr-stak-59a1531649fe0a8de38191771d0b12decfdea072.zip
xmr-stak-59a1531649fe0a8de38191771d0b12decfdea072.tar.gz
fix OSX compile
- link `xmr-stak-backend` to `xmrstak_cuda_backend` to solve missing symboles
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 595631d..4a1da75 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -429,9 +429,7 @@ if(CUDA_FOUND)
)
endif()
target_link_libraries(xmrstak_cuda_backend ${CUDA_LIBRARIES})
- if(CMAKE_CXX_COMPILER_ID MATCHES "MSVC")
- target_link_libraries(xmrstak_cuda_backend xmr-stak-backend)
- endif()
+ target_link_libraries(xmrstak_cuda_backend xmr-stak-backend)
endif()
# compile AMD backend
@@ -444,9 +442,7 @@ if(OpenCL_FOUND)
${OPENCLSRCFILES}
)
target_link_libraries(xmrstak_opencl_backend ${OpenCL_LIBRARY} )
- if(CMAKE_CXX_COMPILER_ID MATCHES "MSVC")
- target_link_libraries(xmrstak_opencl_backend xmr-stak-backend)
- endif()
+ target_link_libraries(xmrstak_opencl_backend xmr-stak-backend)
endif()
# compile final binary
OpenPOWER on IntegriCloud