summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCraig Andrews <candrews@integralblue.com>2018-04-06 14:56:44 -0400
committerTimothy Pearson <tpearson@raptorengineering.com>2018-06-04 21:07:11 +0000
commit21c1e3bac244858470a2ba9d0dd61128b92b0fb2 (patch)
tree2d1188469b2764f4d8a1b00fdce08c7964276e4f /CMakeLists.txt
parent6f987d788c2531f30bce6e209543919d8e512de3 (diff)
downloadxmr-stak-21c1e3bac244858470a2ba9d0dd61128b92b0fb2.zip
xmr-stak-21c1e3bac244858470a2ba9d0dd61128b92b0fb2.tar.gz
Use EXECUTABLE_OUTPUT_PATH and LIBRARY_OUTPUT_PATH
Use EXECUTABLE_OUTPUT_PATH and LIBRARY_OUTPUT_PATH to control the path to which the executable and libraries are installed.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4c74036..2adba65 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -535,23 +535,23 @@ target_link_libraries(xmr-stak ${LIBS} xmr-stak-c xmr-stak-backend)
# do not install the binary if the project and install are equal
if( NOT CMAKE_INSTALL_PREFIX STREQUAL PROJECT_BINARY_DIR )
install(TARGETS xmr-stak
- RUNTIME DESTINATION "${CMAKE_INSTALL_PREFIX}/bin")
+ RUNTIME DESTINATION "${CMAKE_INSTALL_PREFIX}/${EXECUTABLE_OUTPUT_PATH}")
if(CUDA_FOUND)
if(WIN32)
install(TARGETS xmrstak_cuda_backend
- RUNTIME DESTINATION "${CMAKE_INSTALL_PREFIX}/bin")
+ RUNTIME DESTINATION "${CMAKE_INSTALL_PREFIX}/${LIBRARY_OUTPUT_PATH}")
else()
install(TARGETS xmrstak_cuda_backend
- LIBRARY DESTINATION "${CMAKE_INSTALL_PREFIX}/bin")
+ LIBRARY DESTINATION "${CMAKE_INSTALL_PREFIX}/${LIBRARY_OUTPUT_PATH}")
endif()
endif()
if(OpenCL_FOUND)
if(WIN32)
install(TARGETS xmrstak_opencl_backend
- RUNTIME DESTINATION "${CMAKE_INSTALL_PREFIX}/bin")
+ RUNTIME DESTINATION "${CMAKE_INSTALL_PREFIX}/${LIBRARY_OUTPUT_PATH}")
else()
install(TARGETS xmrstak_opencl_backend
- LIBRARY DESTINATION "${CMAKE_INSTALL_PREFIX}/bin")
+ LIBRARY DESTINATION "${CMAKE_INSTALL_PREFIX}/${LIBRARY_OUTPUT_PATH}")
endif()
endif()
else()
OpenPOWER on IntegriCloud