summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authordscho <dscho>2009-02-03 12:22:29 +0000
committerdscho <dscho>2009-02-03 12:22:29 +0000
commit3d2eab575e4af80707bcfcd112d0e2873c8562a6 (patch)
treed165d3db80c82fd4c199306d597ab7fd73f14e2c /test/Makefile.am
parent2475d2c288953e6bf903c36e6e08816dd798abfb (diff)
downloadlibvncserver-3d2eab575e4af80707bcfcd112d0e2873c8562a6.zip
libvncserver-3d2eab575e4af80707bcfcd112d0e2873c8562a6.tar.gz
clean up build flags
The flag handling (both compiler options and include paths) are a mess at the moment. There is no point in forcing "-O2 -g" when these are already the defaults, and if someone changes the defaults, chances are good they don't want you clobbering their choices. The -Wall flag should be handled in configure and thrown into CFLAGS once rather than every Makefile.am. Plus, this way we can control which compilers the flag actually gets used with. Finally, the INCLUDES variable is for -I paths, not AM_CFLAGS. Nor should it contain -I. as this is already in the default includes setup. Signed-off-by: Mike Frysinger <vapier@gentoo.org> Signed-off-by: Johannes Schindelin <johannes.schindelin@gmx.de>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 6abc5e1..82cf181 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,4 +1,4 @@
-AM_CFLAGS=-I $(top_srcdir) -g -Wall
+INCLUDES = -I$(top_srcdir)
LDADD = ../libvncserver/libvncserver.la ../libvncclient/libvncclient.la @WSOCKLIB@
if HAVE_LIBPTHREAD
OpenPOWER on IntegriCloud