summaryrefslogtreecommitdiffstats
path: root/client_examples/Makefile.am
diff options
context:
space:
mode:
authordscho <dscho>2009-03-08 18:33:08 +0000
committerdscho <dscho>2009-03-08 18:33:08 +0000
commitebe79c28c30ad328dcff88b95e7863e885af36f9 (patch)
tree2766085f80235a27b070a8e5eba9cc4dcdbed393 /client_examples/Makefile.am
parente7152a7f68063a86887a9059728ca26b5404ce51 (diff)
downloadlibvncserver-ebe79c28c30ad328dcff88b95e7863e885af36f9.zip
libvncserver-ebe79c28c30ad328dcff88b95e7863e885af36f9.tar.gz
Clipboard support for SDLvncviewer
The clipboard support has only been tested on Linux so far. Signed-off-by: Johannes Schindelin <johannes.schindelin@gmx.de>
Diffstat (limited to 'client_examples/Makefile.am')
-rw-r--r--client_examples/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/client_examples/Makefile.am b/client_examples/Makefile.am
index 9eed084..fa71a50 100644
--- a/client_examples/Makefile.am
+++ b/client_examples/Makefile.am
@@ -19,8 +19,14 @@ SDLVIEWER=SDLvncviewer
SDLvncviewer_CFLAGS=$(SDL_CFLAGS)
+SDLvncviewer_SOURCES=SDLvncviewer.c scrap.c
+
+if HAVE_X
+X11_LIB=-lX11
+endif
+
# thanks to autoconf, this looks ugly
-SDLvncviewer_LDADD=$(LDADD) $(SDL_LIBS)
+SDLvncviewer_LDADD=$(LDADD) $(SDL_LIBS) $(X11_LIB)
endif
noinst_PROGRAMS=ppmtest $(SDLVIEWER) $(FFMPEG_CLIENT) backchannel
OpenPOWER on IntegriCloud