summaryrefslogtreecommitdiffstats
path: root/client_examples/Makefile.am
diff options
context:
space:
mode:
authorMateus Cesar Groess <mateuscg@gmail.com>2012-02-11 19:34:22 +0100
committerChristian Beier <dontmind@freeshell.org>2012-02-11 19:34:22 +0100
commit1078e8a8b050b5b4ebbcb011750f5dd2d8eacc37 (patch)
treec77de6a7641e39324743ca4c26fb402a52626912 /client_examples/Makefile.am
parent4ed29e0a36e043ddf53f572b84004c7fe4d40b1d (diff)
downloadlibvncserver-1078e8a8b050b5b4ebbcb011750f5dd2d8eacc37.zip
libvncserver-1078e8a8b050b5b4ebbcb011750f5dd2d8eacc37.tar.gz
Here is a port of SDLvncviewer to GTK+2.
I think it may encourage people to implement more features for the viewer, because a GTK GUI seems to be easier to implement than a SDL one (and it is more integrated with the major Linux Desktops out there). Signed-off-by: Christian Beier <dontmind@freeshell.org>
Diffstat (limited to 'client_examples/Makefile.am')
-rw-r--r--client_examples/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/client_examples/Makefile.am b/client_examples/Makefile.am
index 8619dc2..2779d53 100644
--- a/client_examples/Makefile.am
+++ b/client_examples/Makefile.am
@@ -28,7 +28,15 @@ endif
SDLvncviewer_LDADD=$(LDADD) $(SDL_LIBS) $(X11_LIB)
endif
-noinst_PROGRAMS=ppmtest $(SDLVIEWER) $(FFMPEG_CLIENT) backchannel
+if HAVE_LIBGTK
+GTKVIEWER=gtkvncviewer
+gtkvncviewer_SOURCES=gtkvncviewer.c
+gtkvncviewer_CFLAGS=$(GTK_CFLAGS)
+gtkvncviewer_LDADD=$(LDADD) $(GTK_LIBS)
+endif
+
+
+noinst_PROGRAMS=ppmtest $(SDLVIEWER) $(GTKVIEWER) $(FFMPEG_CLIENT) backchannel
OpenPOWER on IntegriCloud