summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-tools_2.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-tools_2.3.0.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-tools_2.3.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-tools_2.3.0.bb b/meta/recipes-kernel/lttng/lttng-tools_2.3.0.bb
index 4322027..f2a43b4 100644
--- a/meta/recipes-kernel/lttng/lttng-tools_2.3.0.bb
+++ b/meta/recipes-kernel/lttng/lttng-tools_2.3.0.bb
@@ -33,3 +33,22 @@ FILES_${PN}-dbg += "${libdir}/lttng/libexec/.debug"
# the libexec insane test so skip it.
INSANE_SKIP_${PN} = "libexec"
INSANE_SKIP_${PN}-dbg = "libexec"
+
+
+do_install_ptest () {
+ chmod +x ${D}/${libdir}/${PN}/ptest/tests/utils/utils.sh
+ for i in `find ${D}/${libdir}/${PN}/ptest -perm /u+x -type f`; do
+ sed -e "s:\$TESTDIR.*/src/bin/lttng/\$LTTNG_BIN:\$LTTNG_BIN:" \
+ -e "s:\$TESTDIR/../src/bin/lttng-sessiond/\$SESSIOND_BIN:\$SESSIOND_BIN:" \
+ -e "s:\$DIR/../src/bin/lttng-sessiond/\$SESSIOND_BIN:\$SESSIOND_BIN:" \
+ -e "s:\$TESTDIR/../src/bin/lttng-consumerd/:${libedir}/lttng/libexec/:" \
+ -e "s:\$DIR/../src/bin/lttng-consumerd/:${libdir}/lttng/libexec/:" \
+ -e "s:\$TESTDIR/../src/bin/lttng-relayd/\$RELAYD_BIN:\$RELAYD_BIN:" \
+ -i $i
+ done
+
+ sed -e "s:src/bin/lttng-sessiond:$bindir:" \
+ -e "s:src/bin/lttng-consumerd:${libexecdir}/libexec/:" \
+ -i ${D}/${libdir}/${PN}/ptest/tests/regression/run-report.py
+
+}
OpenPOWER on IntegriCloud