summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-igep_2.6.33.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/linux/linux-igep_2.6.33.5.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-igep_2.6.33.5.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-igep_2.6.33.5.bb b/meta/recipes-kernel/linux/linux-igep_2.6.33.5.bb
new file mode 100644
index 0000000..6e961b7
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-igep_2.6.33.5.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "2.6 Linux Kernel for IGEP based platforms"
+SECTION = "kernel"
+LICENSE = "GPL"
+
+DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_igep0020 = "1"
+DEFAULT_PREFERENCE_igep0030 = "1"
+
+COMPATIBLE_MACHINE = "(igep0020|igep0030)"
+
+inherit kernel
+
+KV = "${PV}-0"
+
+SRC_URI = "http://downloads.igep.es/sources/linux-omap-${KV}.tar.gz \
+ file://0001-omap3-init-MUX-for-OMAP3-IGEP-module.patch;patch=1 \
+ file://defconfig-igep0020 \
+ file://defconfig-igep0030"
+
+do_configure() {
+
+ rm -f ${S}/.config || true
+
+ cp ${WORKDIR}/defconfig-${MACHINE} ${S}/.config
+
+ yes '' | oe_runmake oldconfig
+
+}
+
+S = "${WORKDIR}/linux-omap-${KV}"
OpenPOWER on IntegriCloud