summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libtool/libtool-nativesdk_2.4.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/libtool/libtool-nativesdk_2.4.2.bb')
-rw-r--r--meta/recipes-devtools/libtool/libtool-nativesdk_2.4.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/libtool-nativesdk_2.4.2.bb b/meta/recipes-devtools/libtool/libtool-nativesdk_2.4.2.bb
new file mode 100644
index 0000000..03854f2
--- /dev/null
+++ b/meta/recipes-devtools/libtool/libtool-nativesdk_2.4.2.bb
@@ -0,0 +1,27 @@
+require libtool-${PV}.inc
+
+PR = "${INC_PR}.0"
+SRC_URI += "file://prefix.patch"
+SRC_URI += "file://fixinstall.patch"
+
+inherit nativesdk
+
+do_configure_prepend () {
+ # Remove any existing libtool m4 since old stale versions would break
+ # any upgrade
+ rm -f ${STAGING_DATADIR}/aclocal/libtool.m4
+ rm -f ${STAGING_DATADIR}/aclocal/lt*.m4
+}
+
+do_install () {
+ autotools_do_install
+ install -d ${D}${bindir}/
+ install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/
+}
+
+SYSROOT_PREPROCESS_FUNCS += "libtoolnativesdk_sysroot_preprocess"
+
+libtoolnativesdk_sysroot_preprocess () {
+ install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
+ install -m 755 ${D}${bindir}/${HOST_SYS}-libtool ${SYSROOT_DESTDIR}${bindir_crossscripts}/${HOST_SYS}-libtool
+}
OpenPOWER on IntegriCloud