summaryrefslogtreecommitdiffstats
path: root/meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb')
-rw-r--r--meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb12
1 files changed, 7 insertions, 5 deletions
diff --git a/meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb b/meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb
index 38dd700..6922d69 100644
--- a/meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb
+++ b/meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb
@@ -12,11 +12,13 @@ inherit native
EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
do_compile () {
- oe_runmake smdk2410_config
- oe_runmake tools
+ oe_runmake smdk2410_config
+ oe_runmake tools
}
-do_stage () {
- install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/uboot-mkimage
- ln -sf ${STAGING_BINDIR_NATIVE}/uboot-mkimage ${STAGING_BINDIR_NATIVE}/mkimage
+NATIVE_INSTALL_WORKS = "1"
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
+ ln -sf uboot-mkimage ${D}${bindir}/mkimage
}
OpenPOWER on IntegriCloud