summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-05-31 14:07:08 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-04 11:50:24 +0100
commit158d9d82e0880aca33bfd3312376835ff75735c1 (patch)
tree282eb7c2b4ba9817a1df0383a1cb6e54605ee9b1 /meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb
parent1808552a86c83b53e7f3fa7d88890f661bb98264 (diff)
downloadast2050-yocto-poky-158d9d82e0880aca33bfd3312376835ff75735c1.zip
ast2050-yocto-poky-158d9d82e0880aca33bfd3312376835ff75735c1.tar.gz
alsa-tools: Fix configure race
aclocal is being called here directly, not called by autotools.bbclass wrapper. aclocal files are installed in sysroot, and are removed while build is still running. This translates to a possible race condition during the build. Fixes [YOCTO #4358]. (From OE-Core rev: dea66ade1184cef6aeb242d87867759ca44a8895) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Cristian Iorga <cristian.iorga@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb')
-rw-r--r--meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb b/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb
index 81ad55a..24af545 100644
--- a/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb
+++ b/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb
@@ -20,14 +20,20 @@ SRC_URI[sha256sum] = "553338693707fe6ddfc430b9edc4cd2677390e200c9e38de82ede3394e
inherit autotools
-EXTRA_OEMAKE += "GITCOMPILE_ARGS='--host=${HOST_SYS} --build=${BUILD_SYS} --target=${TARGET_SYS} --with-libtool-sysroot=${STAGING_DIR_HOST} --prefix=${prefix}' ACLOCAL_FLAGS='-I ${STAGING_DATADIR}/aclocal'"
+EXTRA_OEMAKE += "GITCOMPILE_ARGS='--host=${HOST_SYS} --build=${BUILD_SYS} --target=${TARGET_SYS} --with-libtool-sysroot=${STAGING_DIR_HOST} --prefix=${prefix}'"
PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'x11', 'gtk+', '', d)}"
PACKAGECONFIG[gtk+] = ",,gtk+,"
+do_configure () {
+ autotools_do_configure
+ autotools_copy_aclocal
+}
+
do_compile_prepend () {
#Automake dir is not correctly detected in cross compilation case
export AUTOMAKE_DIR=${STAGING_DATADIR_NATIVE}/$(ls ${STAGING_DATADIR_NATIVE} | grep automake)
+ export ACLOCAL="aclocal --system-acdir=${ACLOCALDIR}/"
}
FILES_${PN} += "${datadir}/ld10k1"
OpenPOWER on IntegriCloud