summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf/perf.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-09-07 23:57:29 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-09-10 15:38:56 +0100
commit6cb383cab897b2d3cdcb109a161c1de9e0135e3b (patch)
treeced6a3ec8d6b9dfdac4ee58fa2045fd194e3fae2 /meta/recipes-kernel/perf/perf.bb
parent73ef4032a9ad915fc142ef35248df5c8a30fbfe2 (diff)
downloadast2050-yocto-poky-6cb383cab897b2d3cdcb109a161c1de9e0135e3b.zip
ast2050-yocto-poky-6cb383cab897b2d3cdcb109a161c1de9e0135e3b.tar.gz
perf: fix v3.17 powerpc compilation issues
The powerpc perf arch port has two issues in the current 3.17-rc seriers. Undefined dwarf symbols and undefined pr_debug calls. commit a60335ba [perf tools powerpc: Adjust callchain based on DWARF debug info] introduces skip-callchain-idx.c, and breaks the perf build. Until fixes get into the mainline kernel, we temporarily fix the issues by adding a forced linke to -ldw and modifying skip-callchain-idx.c to include the proper debug files for pr_debug. (From OE-Core rev: 9f204a02f07f8e378e8a078db103a6ba94ec55cb) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/perf/perf.bb')
-rw-r--r--meta/recipes-kernel/perf/perf.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index cbd03f2..8112986 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -78,6 +78,7 @@ EXTRA_OEMAKE = '\
ARCH=${ARCH} \
CC="${CC}" \
AR="${AR}" \
+ EXTRA_CFLAGS="-ldw" \
perfexecdir=${libexecdir} \
NO_GTK2=1 ${TUI_DEFINES} NO_DWARF=1 ${LIBUNWIND_DEFINES} ${SCRIPTING_DEFINES} \
'
@@ -143,6 +144,10 @@ do_configure_prepend () {
if [ -e "${S}/tools/perf/config/feature-checks/Makefile" ]; then
sed -i 's,CC := $(CROSS_COMPILE)gcc -MD,CC += -MD,' ${S}/tools/perf/config/feature-checks/Makefile
fi
+ # 3.17-rc1+ has a include issue for powerpc. Temporarily sed in the appropriate include
+ if [ -e "${S}/tools/perf/arch/powerpc/util/skip-callchain-idx.c" ]; then
+ sed -i 's,#include "util/callchain.h",#include "util/callchain.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/powerpc/util/skip-callchain-idx.c
+ fi
}
python do_package_prepend() {
OpenPOWER on IntegriCloud