summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf/perf.bb
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@linux.intel.com>2013-03-18 23:58:07 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-19 11:54:22 +0000
commit15ab96040f244d398954363f09e5a8110076fd29 (patch)
treed870864f0c3e352ab84cd08bc9cde043c815c149 /meta/recipes-kernel/perf/perf.bb
parent05985a7c22655a2f35ff0fcec723173c404c7993 (diff)
downloadast2050-yocto-poky-15ab96040f244d398954363f09e5a8110076fd29.zip
ast2050-yocto-poky-15ab96040f244d398954363f09e5a8110076fd29.tar.gz
perf: make PKGV match kernel version
Have perf grab and use the kernel version it's built from for PKGV, rather than the default perf recipe version, so the final packages get the kernel version instead of the default 1.0, which represents a backwards value from the previous recipe. (From OE-Core rev: deb99cefe8be7fa63972edadf69f92d361b9a7c5) Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/perf/perf.bb')
-rw-r--r--meta/recipes-kernel/perf/perf.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 3c49922..182dd25 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -32,7 +32,7 @@ RDEPENDS_${PN} += "elfutils bash ${SCRIPTING_RDEPENDS}"
PROVIDES = "virtual/perf"
-inherit kernel-arch pythonnative
+inherit linux-kernel-base kernel-arch pythonnative
# needed for building the tools/perf Python bindings
inherit python-dir
@@ -104,6 +104,10 @@ do_configure_prepend () {
sed -i 's,-Werror ,,' ${S}/tools/perf/Makefile
}
+python do_package_prepend() {
+ bb.data.setVar('PKGV', '${@get_kernelversion('${S}').split("-")[0]}', d)
+}
+
PACKAGE_ARCH = "${MACHINE_ARCH}"
FILES_${PN} += "${libexecdir}/perf-core"
OpenPOWER on IntegriCloud