summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.3.3.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2013-11-14 15:43:49 -0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-20 14:03:27 +0000
commit8d2b5f3c20092e90807cf50c1a633e31e0ee81e9 (patch)
tree89f8e9ef9f63967df7a944a506b78f015e5b05f1 /meta/recipes-kernel/lttng/lttng-modules_2.3.3.bb
parent7ef7e55180a9164bea860ab626d02a5df75f1727 (diff)
downloadast2050-yocto-poky-8d2b5f3c20092e90807cf50c1a633e31e0ee81e9.zip
ast2050-yocto-poky-8d2b5f3c20092e90807cf50c1a633e31e0ee81e9.tar.gz
lttng-modules: Update to 2.3.3 version
This updates lttng-modules for 2.3.3 and it also fixes the build with 3.12 Linux kernel. While on that, we also renamed the recipe file to follow the other lttng recipes which use the version number on it. (From OE-Core rev: 2d01bd48e689656bbe6189243d077f822092a14a) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.3.3.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.3.3.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.3.3.bb b/meta/recipes-kernel/lttng/lttng-modules_2.3.3.bb
new file mode 100644
index 0000000..f293376
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.3.3.bb
@@ -0,0 +1,34 @@
+SECTION = "devel"
+SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
+DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
+LICENSE = "LGPLv2.1 & GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1412caf5a1aa90d6a48588a4794c0eac \
+ file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
+ file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad"
+
+DEPENDS = "virtual/kernel"
+
+inherit module
+
+SRCREV = "eef112db0e63feff6cbf0a98cda9af607cefb377"
+PV = "2.3.3"
+
+SRC_URI = "git://git.lttng.org/lttng-modules.git \
+ file://lttng-modules-replace-KERNELDIR-with-KERNEL_SRC.patch"
+
+export INSTALL_MOD_DIR="kernel/lttng-modules"
+export KERNEL_SRC="${STAGING_KERNEL_DIR}"
+
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+ # Delete empty directories to avoid QA failures if no modules were built
+ find ${D}/lib -depth -type d -empty -exec rmdir {} \;
+}
+
+python do_package_prepend() {
+ if not os.path.exists(os.path.join(d.getVar('D', True), 'lib/modules')):
+ bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN', True))
+}
+
OpenPOWER on IntegriCloud