summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2013-06-14 14:38:19 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-07-29 13:09:00 +0100
commit0a3d3b606e8991b0e76b3eec110ffc36a3430073 (patch)
treedc16ac3e4aee54ae14586205e917a38a2e7b5dc2 /meta/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb
parent054b932f7bb8b9c49a5663dfb6f32ae90d4a6046 (diff)
downloadast2050-yocto-poky-0a3d3b606e8991b0e76b3eec110ffc36a3430073.zip
ast2050-yocto-poky-0a3d3b606e8991b0e76b3eec110ffc36a3430073.tar.gz
xinput-calibrator: move it from meta-oe to oe-core
People using xserver-xorg that need to calibrate their touchscreen devices would also need meta-oe. Bringing the recipes to oe-core will make it easier for them. Aditionaly: * drop xterm RDEPENDS. Terminal is not needed to run the menu item; * change xinput_calibrator_pointercal.sh so that it can be run as normal user: pointercal.xinput is saved to ~/.pointercal/ and it will be used when the system boots; * have the calibration run through an Xsession file; * remove the systemd service since calibration is run by Xsession; * do not install pointercal.xinput if it's the default one; [YOCTO #4416] (From OE-Core rev: 4ecafd89dbf41cbd53e6db32678fe625c06caaab) Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb')
-rw-r--r--meta/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb b/meta/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb
new file mode 100644
index 0000000..2e9dc03
--- /dev/null
+++ b/meta/recipes-graphics/xinput-calibrator/pointercal-xinput_0.0.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Touchscreen calibration data from xinput-calibrator"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+PR = "r4"
+
+SRC_URI = "file://pointercal.xinput"
+S = "${WORKDIR}"
+
+do_install() {
+ # Only install file if it has a contents
+ if [ -s ${S}/pointercal.xinput ] &&\
+ [ ! -n "$(head -n1 ${S}/pointercal.xinput|grep "replace.*pointercal\.xinput")" ]; then
+ install -d ${D}${sysconfdir}/
+ install -m 0644 ${S}/pointercal.xinput ${D}${sysconfdir}/
+ fi
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+CONFFILES_${PN} = "${sysconfdir}/pointercal.xinput"
OpenPOWER on IntegriCloud