summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/qemugl_git.bb
diff options
context:
space:
mode:
authorScott Garman <scott.a.garman@intel.com>2012-04-17 23:10:30 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-18 00:22:56 +0100
commitabddce33ac3a736d497e54cc1c424cbddac27b8e (patch)
treec391c18b381009fd2d67c32fb21db7dc52adf6c1 /meta/recipes-graphics/mesa/qemugl_git.bb
parenta8c668c43a3f0e63d1072cf41a9427de2e665d36 (diff)
downloadast2050-yocto-poky-abddce33ac3a736d497e54cc1c424cbddac27b8e.zip
ast2050-yocto-poky-abddce33ac3a736d497e54cc1c424cbddac27b8e.tar.gz
qemugl: make postinst run at first boot
The previous postinst script was not working for images which use RPM because do_rootfs could allow qemugl to be installed after libgl1, and the postinst needs to run after libgl1 is installed. Hence, it's being changed to run at first boot instead of during do_rootfs. (From OE-Core rev: dc0fe3fbf9ca862c1d0d90468e6da326f58e3b41) Signed-off-by: Scott Garman <scott.a.garman@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/mesa/qemugl_git.bb')
-rw-r--r--meta/recipes-graphics/mesa/qemugl_git.bb16
1 files changed, 11 insertions, 5 deletions
diff --git a/meta/recipes-graphics/mesa/qemugl_git.bb b/meta/recipes-graphics/mesa/qemugl_git.bb
index 378aa65..32980d3 100644
--- a/meta/recipes-graphics/mesa/qemugl_git.bb
+++ b/meta/recipes-graphics/mesa/qemugl_git.bb
@@ -19,7 +19,7 @@ S = "${WORKDIR}/git"
SRCREV = "d888bbc723c00d197d34a39b5b7448660ec1b1c0"
PV = "0.0+git${SRCPV}"
-PR = "r10"
+PR = "r11"
DEFAULT_PREFERENCE = "-1"
@@ -34,11 +34,17 @@ do_install () {
fi
}
+# This cannot be converted to run at pacakge install time, because
+# it depends on being run after the libgl1 package is installed,
+# and RPM cannot guarantee the order of pacakge insallation.
pkg_postinst_${PN} () {
- if [ "${PN}" != "qemugl-nativesdk" ]; then
- rm -f $D${libdir}/libGL.so.1.2
- ln -s libGL-qemu.so.1.2 $D${libdir}/libGL.so.1.2
- fi
+#!/bin/sh -e
+if [ x"$D" = "x" ]; then
+ rm -f ${libdir}/libGL.so.1.2
+ ln -s libGL-qemu.so.1.2 ${libdir}/libGL.so.1.2
+else
+ exit 1
+fi
}
BBCLASSEXTEND = "nativesdk"
OpenPOWER on IntegriCloud