summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa-dri_7.9.bb
diff options
context:
space:
mode:
authorYu Ke <ke.yu@intel.com>2010-11-24 12:51:42 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-12-02 05:24:57 -0800
commit742f217ac29577194fcdaec61117e04d26213220 (patch)
tree93748ec0576bdc9f219b3c91c74c2fd9baeff85e /meta/recipes-graphics/mesa/mesa-dri_7.9.bb
parent2e95941ef0cc1638f3e4774256a736f3996f63fa (diff)
downloadast2050-yocto-poky-742f217ac29577194fcdaec61117e04d26213220.zip
ast2050-yocto-poky-742f217ac29577194fcdaec61117e04d26213220.tar.gz
mesa-dri: upgrade from 7.8.2 to 7.9
with the following changes: - remove mesa-demos, because starting from mesa 7.9, mesa-demos becomes a standalone src tar ball in upstream, so there will be a seperate recipes to build the mesa-demos - add dependency of talloc and libxml2-native Signed-off-by: Yu Ke <ke.yu@intel.com>
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa-dri_7.9.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa-dri_7.9.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-dri_7.9.bb b/meta/recipes-graphics/mesa/mesa-dri_7.9.bb
new file mode 100644
index 0000000..6f0f984
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa-dri_7.9.bb
@@ -0,0 +1,38 @@
+include mesa-common.inc
+
+LIC_FILES_CHKSUM = "file://docs/license.html;md5=7a3373c039b6b925c427755a4f779c1d"
+
+PROTO_DEPS = "xf86driproto glproto dri2proto"
+LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat \
+ libxml2-native talloc"
+
+DEPENDS = "${PROTO_DEPS} ${LIB_DEPS} mesa-dri-glsl-native"
+
+PR = "r0"
+
+SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2 \
+ file://crossfix.patch"
+
+# most of our targets do not have DRI so will use mesa-xlib
+DEFAULT_PREFERENCE = "-1"
+
+# Atom PCs have DRI support so use mesa-dri by default
+DEFAULT_PREFERENCE_atom-pc = "1"
+
+LEAD_SONAME = "libGL.so.1"
+
+EXTRA_OECONF += "--with-driver=dri --disable-egl --disable-gallium"
+
+python populate_packages_prepend() {
+ import os.path
+
+ dri_drivers_root = os.path.join(bb.data.getVar('libdir', d, 1), "dri")
+
+ do_split_packages(d, dri_drivers_root, '^(.*)_dri\.so$', 'mesa-dri-driver-%s', 'Mesa %s DRI driver', extra_depends='')
+}
+
+COMPATIBLE_HOST = '(i.86.*-linux|x86_64.*-linux)'
+
+PACKAGES_DYNAMIC = "mesa-dri-driver-*"
+
+FILES_${PN}-dbg += "${libdir}/dri/.debug/*"
OpenPOWER on IntegriCloud