summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/texinfo-dummy-native/texinfo-dummy-native.bb
diff options
context:
space:
mode:
authorMax Eliaser <max.eliaser@intel.com>2014-06-10 13:24:15 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-13 12:31:38 +0100
commit0a4ba77f66aff34fe7781f209cea9a012ff9d8e5 (patch)
treea2812dcfe3081764ce7768668d515b71a62f7634 /meta/recipes-extended/texinfo-dummy-native/texinfo-dummy-native.bb
parenta6815586798b02fd25d96590dda1d042392686fa (diff)
downloadast2050-yocto-poky-0a4ba77f66aff34fe7781f209cea9a012ff9d8e5.zip
ast2050-yocto-poky-0a4ba77f66aff34fe7781f209cea9a012ff9d8e5.tar.gz
texinfo-dummy-native: Create recipe w/ scripts to stand in for Texinfo utils.
More work toward eliminating the dependency on the host system's Texinfo-- Python scripts that understand the same command-line options as the Texinfo utilities, and create blank output files if appropriate, but don't actually do any of the work done by those utilities. This will be necessary to avoid circular dependencies when we start explicitly tracking dependencies on texinfo-native; i.e. texinfo-native -> autoconf-native -> texinfo-native. If we have all native recipes that inherit texinfo.bbclass depend on texinfo-dummy-native instead of texinfo-native, the cycle is broken. It may also provide a performance gain by skipping the actual work of formatting and generating documentation files. (From OE-Core rev: 0d8d5a2d44988d32a5c8b995202a12ac106ba93c) Signed-off-by: Max Eliaser <max.eliaser@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/texinfo-dummy-native/texinfo-dummy-native.bb')
-rw-r--r--meta/recipes-extended/texinfo-dummy-native/texinfo-dummy-native.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-extended/texinfo-dummy-native/texinfo-dummy-native.bb b/meta/recipes-extended/texinfo-dummy-native/texinfo-dummy-native.bb
new file mode 100644
index 0000000..b5420a3
--- /dev/null
+++ b/meta/recipes-extended/texinfo-dummy-native/texinfo-dummy-native.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Fake version of the texinfo utility suite"
+SECTION = "console/utils"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d6bb62e73ca8b901d3f2e9d71542f4bb"
+DEPENDS = ""
+PV = "1.0"
+
+SRC_URI = "file://template.py file://COPYING"
+
+S = "${WORKDIR}"
+
+NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}"
+
+inherit native
+
+do_install_name() {
+ FILENAME="${D}${bindir}/$1"
+ # Using ln causes problems with rm_work
+ cp -T "${S}/template.py" "$FILENAME"
+ chmod +x $FILENAME
+}
+
+do_install() {
+ mkdir -p "${D}${bindir}"
+ for i in makeinfo pod2texi texi2dvi pdftexi2dvi texindex texi2pdf \
+ txixml2texi texi2any install-info ginstall-info \
+ update-info-dir; do
+ do_install_name $i
+ done
+}
OpenPOWER on IntegriCloud