summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/slang/slang_2.2.4.bb
diff options
context:
space:
mode:
authorRoy.Li <rongqing.li@windriver.com>2012-07-10 17:27:00 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-17 10:53:54 +0100
commit6c401a907c16401b524cc7fb21b345eece5fead0 (patch)
treecec4ad2f4a1e1a99fc800478aa0ca54172a93662 /meta/recipes-extended/slang/slang_2.2.4.bb
parente72157e71c7e3a823d83253f68a9af881e2ab2a0 (diff)
downloadast2050-yocto-poky-6c401a907c16401b524cc7fb21b345eece5fead0.zip
ast2050-yocto-poky-6c401a907c16401b524cc7fb21b345eece5fead0.tar.gz
slang: change char type to signed char in macros
Fix [YOCTO 2726] C language has 3 distinct char types: char unsigned char signed char A char has the same range of values as signed char on X86, but same as unsigned char on ARM which made Slang's typecast() and array_sort() unable to work for char value on ARM, since Slang is assuming "char" as "signed char". Now we change "char" as "signed char" explicitly in util/mkslarith2.sl, and use it to regenerate src/slarith2.inc (From OE-Core rev: 0a1d842e2db63265a6a6708b1101e1f52f223fc9) Signed-off-by: Roy.Li <rongqing.li@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/slang/slang_2.2.4.bb')
-rw-r--r--meta/recipes-extended/slang/slang_2.2.4.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-extended/slang/slang_2.2.4.bb b/meta/recipes-extended/slang/slang_2.2.4.bb
index f17bc0f..72dd99f 100644
--- a/meta/recipes-extended/slang/slang_2.2.4.bb
+++ b/meta/recipes-extended/slang/slang_2.2.4.bb
@@ -10,7 +10,7 @@ to recode S-Lang procedures in C if you need to."
HOMEPAGE = "http://www.jedsoft.org/slang/"
SECTION = "libs"
DEPENDS = "pcre"
-PR = "r8"
+PR = "r9"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=a52a18a472d4f7e45479b06563717c02"
@@ -19,6 +19,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=a52a18a472d4f7e45479b06563717c02"
SRC_URI = "ftp://space.mit.edu/pub/davis/slang/v2.2/slang-${PV}.tar.bz2 \
file://rpathfix.patch \
"
+SRC_URI_append_arm = " file://change-char-type-to-signed-char-in-macros.patch"
inherit autotools
OpenPOWER on IntegriCloud