summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/grep/grep_2.21.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2014-12-26 17:35:33 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-27 22:53:39 +0000
commit16d74f8da855c3042ae6731a666501b56ad532fc (patch)
tree6be4964ef7281e395bf21d9ec1190d510f5bd3d7 /meta/recipes-extended/grep/grep_2.21.bb
parent088d4bb85cf7722723d2520585b74d3f7eddaafe (diff)
downloadast2050-yocto-poky-16d74f8da855c3042ae6731a666501b56ad532fc.zip
ast2050-yocto-poky-16d74f8da855c3042ae6731a666501b56ad532fc.tar.gz
grep: upgrade to 2.21
(From OE-Core rev: f7a927a266ef08ea5c61b682e345a477a460d98b) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/grep/grep_2.21.bb')
-rw-r--r--meta/recipes-extended/grep/grep_2.21.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-extended/grep/grep_2.21.bb b/meta/recipes-extended/grep/grep_2.21.bb
new file mode 100644
index 0000000..2c378d8
--- /dev/null
+++ b/meta/recipes-extended/grep/grep_2.21.bb
@@ -0,0 +1,39 @@
+SUMMARY = "GNU grep utility"
+HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
+BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep"
+SECTION = "console/utils"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=8006d9c814277c1bfc4ca22af94b59ee"
+
+SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.xz"
+
+SRC_URI[md5sum] = "43c48064d6409862b8a850db83c8038a"
+SRC_URI[sha256sum] = "5244a11c00dee8e7e5e714b9aaa053ac6cbfa27e104abee20d3c778e4bb0e5de"
+
+inherit autotools gettext texinfo
+
+EXTRA_OECONF = "--disable-perl-regexp"
+
+do_configure_prepend () {
+ rm -f ${S}/m4/init.m4
+}
+
+do_install () {
+ autotools_do_install
+ install -d ${D}${base_bindir}
+ mv ${D}${bindir}/grep ${D}${base_bindir}/grep
+ mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep
+ mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep
+ rmdir ${D}${bindir}/
+}
+
+inherit update-alternatives
+
+ALTERNATIVE_PRIORITY = "100"
+
+ALTERNATIVE_${PN} = "grep egrep fgrep"
+ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
+ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
+ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"
+
+export CONFIG_SHELL="/bin/sh"
OpenPOWER on IntegriCloud