summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-11-28 11:48:42 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-06 12:31:05 +0000
commite60be76f431dd3bf2ec57ea0271ac97c327fa95c (patch)
treed0cae55209790769ba0cf631628d1f74512e1bff /meta/recipes-devtools/python/python-smartpm_1.4.1.bb
parent69b9c6bd0c6f9c9884fa2d92b4062037457d06ad (diff)
downloadast2050-yocto-poky-e60be76f431dd3bf2ec57ea0271ac97c327fa95c.zip
ast2050-yocto-poky-e60be76f431dd3bf2ec57ea0271ac97c327fa95c.tar.gz
python-smartpm: style fixes
* Use ${PN} instead of python-smartpm * Use multi-line strings instead of multiple single line += (also avoiding the confusing "_append +=") * Use class-native instead of virtclass-native - no difference in behaviour, but this keeps things consistent if we have to add any target overrides in future. (From OE-Core rev: 7dbe5004380b97949a7910706364ba57c6c52a33) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-smartpm_1.4.1.bb')
-rw-r--r--meta/recipes-devtools/python/python-smartpm_1.4.1.bb48
1 files changed, 23 insertions, 25 deletions
diff --git a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
index 9048bc8..ff153a7 100644
--- a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
+++ b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
@@ -28,13 +28,13 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
# Options - rpm, qt4, gtk
PACKAGECONFIG ??= "rpm"
-RPM_RDEP = "python-smartpm-backend-rpm"
-QT_RDEP = "python-smartpm-interface-qt4"
-GTK_RDEP = "python-smartpm-interface-gtk"
+RPM_RDEP = "${PN}-backend-rpm"
+QT_RDEP = "${PN}-interface-qt4"
+GTK_RDEP = "${PN}-interface-gtk"
-RPM_RDEP_virtclass-native = ""
-QT_RDEP_virtclass-native = ""
-GTK_RDEP_virtclass-native = ""
+RPM_RDEP_class-native = ""
+QT_RDEP_class-native = ""
+GTK_RDEP_class-native = ""
PACKAGECONFIG[rpm] = ",,rpm,${RPM_RDEP}"
PACKAGECONFIG[qt4] = ",,qt4-x11,${QT_RDEP}"
@@ -85,35 +85,33 @@ do_install_append() {
fi
}
-PACKAGES = "python-smartpm-dev python-smartpm-dbg python-smartpm-doc smartpm"
-PACKAGES += "${@base_contains('PACKAGECONFIG', 'rpm', 'python-smartpm-backend-rpm', '', d)}"
-PACKAGES += "${@base_contains('PACKAGECONFIG', 'qt4', 'python-smartpm-interface-qt4', '', d)}"
-PACKAGES += "${@base_contains('PACKAGECONFIG', 'gtk', 'python-smartpm-interface-gtk', '', d)}"
-PACKAGES += "python-smartpm-interface-images"
-PACKAGES += "python-smartpm"
+PACKAGES = "${PN}-dev ${PN}-dbg ${PN}-doc smartpm \
+ ${@base_contains('PACKAGECONFIG', 'rpm', '${PN}-backend-rpm', '', d)} \
+ ${@base_contains('PACKAGECONFIG', 'qt4', '${PN}-interface-qt4', '', d)} \
+ ${@base_contains('PACKAGECONFIG', 'gtk', '${PN}-interface-gtk', '', d)} \
+ ${PN}-interface-images ${PN}"
-RDEPENDS_smartpm = 'python-smartpm'
+RDEPENDS_smartpm = "${PN}"
-RDEPENDS_python-smartpm_append = " python-smartpm-backend-rpm python-codecs python-textutils python-xml"
-RDEPENDS_python-smartpm_append += " python-fcntl python-pickle python-crypt python-compression python-shell"
-RDEPENDS_python-smartpm_append += " python-resource python-netclient python-threading python-unixadmin"
+RDEPENDS_${PN} += "${PN}-backend-rpm python-codecs python-textutils python-xml python-fcntl \
+ python-pickle python-crypt python-compression python-shell \
+ python-resource python-netclient python-threading python-unixadmin"
+RDEPENDS_${PN}_class-native = ""
-#RDEPENDS_python-smartpm_append += " python-modules"
+RDEPENDS_${PN}-backend-rpm = "python-rpm"
-RDEPENDS_python-smartpm-backend-rpm = 'python-rpm'
-
-RDEPENDS_python-smartpm-interface-qt4 = 'qt4-x11 python-smartpm-interface-images'
-RDEPENDS_python-smartpm-interface-gtk = 'gtk+ python-smartpm-interface-images'
+RDEPENDS_${PN}-interface-qt4 = "qt4-x11 ${PN}-interface-images"
+RDEPENDS_${PN}-interface-gtk = "gtk+ ${PN}-interface-images"
FILES_smartpm = "${bindir}/smart"
FILES_${PN}-dbg += "${libdir}/python*/site-packages/smart/backends/rpm/.debug"
-FILES_python-smartpm-backend-rpm = "${libdir}/python*/site-packages/smart/backends/rpm"
+FILES_${PN}-backend-rpm = "${libdir}/python*/site-packages/smart/backends/rpm"
-FILES_python-smartpm-interface-qt4 = "${libdir}/python*/site-packages/smart/interfaces/qt4"
-FILES_python-smartpm-interface-gtk = "${libdir}/python*/site-packages/smart/interfaces/gtk"
-FILES_python-smartpm-interface-images = "${datadir}/${baselib}/python*/site-packages/smart/interfaces/images"
+FILES_${PN}-interface-qt4 = "${libdir}/python*/site-packages/smart/interfaces/qt4"
+FILES_${PN}-interface-gtk = "${libdir}/python*/site-packages/smart/interfaces/gtk"
+FILES_${PN}-interface-images = "${datadir}/${baselib}/python*/site-packages/smart/interfaces/images"
BBCLASSEXTEND = "native"
OpenPOWER on IntegriCloud