summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-setuptools_0.6c11.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-12 14:17:06 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-14 13:18:06 +0100
commita74c33d157e4ac7a732524860786d76797ca0249 (patch)
tree326c13dc951f48c1988abda87b3cb86daa5afa61 /meta/recipes-devtools/python/python-setuptools_0.6c11.bb
parentabeb5d580a77e80d7486ada95ff89a20f1792128 (diff)
downloadast2050-yocto-poky-a74c33d157e4ac7a732524860786d76797ca0249.zip
ast2050-yocto-poky-a74c33d157e4ac7a732524860786d76797ca0249.tar.gz
Import python-setuptools from meta-oe (for glib-2.0)
(From OE-Core rev: d93ffea3164952954557a5a3dc90cebbd46272b2) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-setuptools_0.6c11.bb')
-rw-r--r--meta/recipes-devtools/python/python-setuptools_0.6c11.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-setuptools_0.6c11.bb b/meta/recipes-devtools/python/python-setuptools_0.6c11.bb
new file mode 100644
index 0000000..75bce3f
--- /dev/null
+++ b/meta/recipes-devtools/python/python-setuptools_0.6c11.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Download, build, install, upgrade, and uninstall Python packages"
+HOMEPAGE = "http://cheeseshop.python.org/pypi/setuptools"
+SECTION = "devel/python"
+LICENSE = "PSF"
+LIC_FILES_CHKSUM = "file://setup.py;beginline=23;endline=23;md5=8a314270dd7a8dbca741775415f1716e"
+
+SRCNAME = "setuptools"
+PR = "ml2"
+DEPENDS += "python"
+DEPENDS_virtclass-native += "python-native"
+
+SRC_URI = "\
+ http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz\
+"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_install_prepend() {
+ install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
+}
+
+RDEPENDS_${PN} = "\
+ python-distutils \
+ python-compression \
+"
+
+SRC_URI[md5sum] = "7df2a529a074f613b509fb44feefe74e"
+SRC_URI[sha256sum] = "630fea9b726320b73ee3ca6ff61732cb32675b0389be658080fe46383b87a1d3"
+
+BBCLASSEXTEND = "native"
OpenPOWER on IntegriCloud