summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl_5.12.3.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2011-07-01 11:51:15 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-01 23:27:25 +0100
commit46c11ac20e226a1ebb3947ae948339ab16e6dbc9 (patch)
tree85ff80f4d9d2196a17b58712780ed7818cee93b2 /meta/recipes-devtools/perl/perl_5.12.3.bb
parentffc7ca72c53a7908f8d8bb3597cc8cfdf058bf88 (diff)
downloadast2050-yocto-poky-46c11ac20e226a1ebb3947ae948339ab16e6dbc9.zip
ast2050-yocto-poky-46c11ac20e226a1ebb3947ae948339ab16e6dbc9.tar.gz
perl: Fix package qa rpath warnings.
Fix these kinds of Package QA warnings before they are converted into fetal errors: WARNING: QA Issue: package perl-module-compress contains bad RPATH /build_disk/poky_build/build0/tmp/sysroots/qemux86/usr/lib in file /build_disk/poky_build/build0/tmp/work/i586-poky-linux/perl-5.12.3-r1/packages-split/perl-module-compress/usr/lib/perl/5.12.3/auto/Compress/Raw/Zlib/Zlib.so This fixes this warning for perl recipe as well as libxml-parser-perl recipe. It is a fix to MakeMaker within perl, so all such perl recipes will get fixed with this perl fix. (From OE-Core rev: a67e0c0e01a22718a617a82f54575b77928249ee) Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/perl_5.12.3.bb')
-rw-r--r--meta/recipes-devtools/perl/perl_5.12.3.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.12.3.bb b/meta/recipes-devtools/perl/perl_5.12.3.bb
index b053482..850eef2 100644
--- a/meta/recipes-devtools/perl/perl_5.12.3.bb
+++ b/meta/recipes-devtools/perl/perl_5.12.3.bb
@@ -8,7 +8,7 @@ PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db grep-native"
DEPENDS += "gdbm zlib"
-PR = "r1"
+PR = "r2"
# 5.10.1 has Module::Build built-in
PROVIDES += "libmodule-build-perl"
@@ -68,6 +68,7 @@ SRC_URI = "http://www.cpan.org/src/5.0/perl-${PV}.tar.gz \
file://native-perlinc.patch \
file://perl-enable-gdbm.patch \
file://cross-generate_uudmap.patch \
+ file://fix_bad_rpath.patch \
\
file://config.sh \
file://config.sh-32 \
@@ -178,7 +179,8 @@ do_configure() {
do_compile() {
sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' ext/Errno/Errno_pm.PL
sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' cpan/Compress-Raw-Zlib/config.in
- sed -i -e 's|/usr/lib|${STAGING_LIBDIR}|g' cpan/Compress-Raw-Zlib/config.in
+ sed -i -e 's|/usr/lib|""|g' cpan/Compress-Raw-Zlib/config.in
+ sed -i -e 's|SYSROOTLIB|${STAGING_LIBDIR}|g' cpan/ExtUtils-MakeMaker/lib/ExtUtils/Liblist/Kid.pm
cd Cross
oe_runmake perl LD="${CCLD}"
OpenPOWER on IntegriCloud