summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/mkelfimage/mkelfimage_svn.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-07-14 14:14:07 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-17 10:54:02 +0100
commit85e5f2d8ac4e4096b5f4dbf4c5cb66680777d54d (patch)
treed65403c761fa668b6931f0060bd3005cfbde5f39 /meta/recipes-devtools/mkelfimage/mkelfimage_svn.bb
parent0a925c9dcf0768ffa1d2dca2a8aaeee65919d52f (diff)
downloadast2050-yocto-poky-85e5f2d8ac4e4096b5f4dbf4c5cb66680777d54d.zip
ast2050-yocto-poky-85e5f2d8ac4e4096b5f4dbf4c5cb66680777d54d.tar.gz
mkelfimage: Fix cross build
This patch fixes building this tool in cross environment It uses tools such as CC, HOST_CC, I386_CC etc. and as long as you are building native it does not matter since they all are same namely 'gcc' but in cross compiling that wont work. So we make the makefiles and configure scripts aware of that fact Upstream hosts this program in a svn repo. So change the SRC_URI to official svn repo. With git we were checking out a lot more that just mkelfimage which is not required. There were unpackaged empty directories too so we make sure they are removed as well. Fixes Yocto bug# 2765 (From OE-Core rev: 0d828f19f7ef2d852bbe6da4510efea76a39b982) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/mkelfimage/mkelfimage_svn.bb')
-rw-r--r--meta/recipes-devtools/mkelfimage/mkelfimage_svn.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/mkelfimage/mkelfimage_svn.bb b/meta/recipes-devtools/mkelfimage/mkelfimage_svn.bb
new file mode 100644
index 0000000..c670f23
--- /dev/null
+++ b/meta/recipes-devtools/mkelfimage/mkelfimage_svn.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "A utility to create ELF boot images from Linux kernel images"
+HOMEPAGE = "http://www.coreboot.org/Mkelfimage"
+SECTION = "devel"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=ea5bed2f60d357618ca161ad539f7c0a"
+
+SRCREV = "6637"
+PV = "1.0.0+svn${SRCPV}"
+PR = "r1"
+
+DEPENDS += "zlib"
+
+SRC_URI = "svn://coreboot.org/coreboot/trunk/util;module=mkelfImage \
+ file://cross-compile.patch \
+ "
+
+S = "${WORKDIR}/mkelfImage"
+
+CFLAGS += "-fno-stack-protector"
+CACHED_CONFIGUREVARS += "HOST_CC='${BUILD_CC}'"
+EXTRA_OEMAKE += "HOST_CPPFLAGS='${BUILD_CPPFLAGS}'"
+
+inherit autotools
+
+do_install_append() {
+ rmdir ${D}${datadir}/mkelfImage/elf32-i386
+ rmdir ${D}${datadir}/mkelfImage
+}
+
+BBCLASSEXTEND = "native"
OpenPOWER on IntegriCloud