summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/build-compare/build-compare_git.bb
diff options
context:
space:
mode:
authorRandy Witt <randy.e.witt@linux.intel.com>2015-02-11 16:24:12 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-15 21:58:28 +0000
commitc0a79410b9ac27c79bd53444567de5546db51d0a (patch)
treeb99dc93b9ba38f3baefd33f7b52f00a2bc91c9c0 /meta/recipes-devtools/build-compare/build-compare_git.bb
parentc0a1f43aadbf1e18a4e0a402126f80955f15b446 (diff)
downloadast2050-yocto-poky-c0a79410b9ac27c79bd53444567de5546db51d0a.zip
ast2050-yocto-poky-c0a79410b9ac27c79bd53444567de5546db51d0a.tar.gz
build-compare: Add the build-compare_git.bb recipe.
The description for build-compare describes it as "This package contains scripts to find out if the build result differs to a former build." More specifically this contains a script that will display differences between "packages." It works with rpms, tarballs and other various types of packages. The idea is that it will eventually be used in Yocto to check for differences between sstate so that we can check for build reproducibility. It will also be used once an updateable sdk is in place, so that packages that have different hashes but are not different in contents, don't get updated. It could also be used in the same manner when updating packages from a package feed. [Yocto #6992] (From OE-Core rev: 48387f0c0c4cccc8bc89afd121b7d8315475964a) Signed-off-by: Randy Witt <randy.e.witt@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/build-compare/build-compare_git.bb')
-rw-r--r--meta/recipes-devtools/build-compare/build-compare_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/build-compare/build-compare_git.bb b/meta/recipes-devtools/build-compare/build-compare_git.bb
new file mode 100644
index 0000000..418aee0
--- /dev/null
+++ b/meta/recipes-devtools/build-compare/build-compare_git.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Build Result Compare Script"
+DESCRIPTION = "This package contains scripts to find out if the build result\
+differs to a former build."
+HOMEPAGE = "https://github.com/openSUSE/build-compare"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+SRC_URI = "git://github.com/openSUSE/build-compare.git"
+SRC_URI += "file://Rename-rpm-check.sh-to-pkg-diff.sh.patch;striplevel=1"
+SRC_URI += "file://Ignore-DWARF-sections.patch;striplevel=1"
+PATCHTOOL = "git"
+
+SRCREV = "c5352c054c6ef15735da31b76d6d88620f4aff0a"
+
+S = "${WORKDIR}/git"
+
+BBCLASSEXTEND += "native nativesdk"
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 755 functions.sh ${D}/${bindir}
+ install -m 755 pkg-diff.sh ${D}/${bindir}
+ install -m 755 same-build-result.sh ${D}/${bindir}
+ install -m 755 srpm-check.sh ${D}/${bindir}
+}
+
+RDEPENDS_${PN} += "bash"
OpenPOWER on IntegriCloud