summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/uclibc/uclibc_0.9.30.1.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-core/uclibc/uclibc_0.9.30.1.bb
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadast2050-yocto-poky-29d6678fd546377459ef75cf54abeef5b969b5cf.zip
ast2050-yocto-poky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-core/uclibc/uclibc_0.9.30.1.bb')
-rw-r--r--meta/recipes-core/uclibc/uclibc_0.9.30.1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-core/uclibc/uclibc_0.9.30.1.bb b/meta/recipes-core/uclibc/uclibc_0.9.30.1.bb
new file mode 100644
index 0000000..6bdf153
--- /dev/null
+++ b/meta/recipes-core/uclibc/uclibc_0.9.30.1.bb
@@ -0,0 +1,33 @@
+# UCLIBC_BASE should be the latest released revision of uclibc (that way
+# the config files will typically be correct!) uclibc-cvs takes precedence
+# over uclibc-${UCLIBC_BASE}, if a config file in uclibc-cvs is out of date
+# try removing it
+#
+# UCLIBC_BASE can be set in a distro file, but whether this works depends
+# on whether the base patches apply to the selected (SRCDATE) svn release.
+#
+UCLIBC_BASE ?= "0.9.30.1"
+
+require uclibc.inc
+PR = "r1"
+
+PROVIDES += "virtual/${TARGET_PREFIX}libc-for-gcc"
+
+SRC_URI += "file://uClibc.machine file://uClibc.distro \
+ file://arm-linuxthreads.patch;patch=1 \
+ file://linuxthreads-changes.patch;patch=1 \
+ file://pthread_atfork.patch;patch=1 \
+ file://uclibc_ldso_use_O0.patch;patch=1 \
+ file://ldso_use_arm_dl_linux_resolve_in_thumb_mode.patch;patch=1 \
+ file://gcc-4.4-fixlet.patch;patch=1 \
+ file://uclibc-c99-ldbl-math.patch;patch=1 \
+ file://Use-__always_inline-instead-of-__inline__.patch;patch=1 \
+ "
+#recent versions uclibc require real kernel headers
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+#as stated above, uclibc needs real kernel-headers
+#however: we can't depend on virtual/kernel when nptl hits due to depends deadlocking ....
+KERNEL_SOURCE = "${STAGING_DIR_HOST}/${exec_prefix}"
+
+S = "${WORKDIR}/uClibc-${UCLIBC_BASE}"
OpenPOWER on IntegriCloud