summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd_208.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2014-02-26 15:49:52 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-28 14:01:12 +0000
commitd2f5f2b0b129a654ae8b3ff3f048b582c93c385b (patch)
tree7c95ae2de7fec0dfa0b83880ac1c7816b8f5755a /meta/recipes-core/systemd/systemd_208.bb
parent49cdb68e3bfa885e7eaf67aec97631413f53bdf3 (diff)
downloadast2050-yocto-poky-d2f5f2b0b129a654ae8b3ff3f048b582c93c385b.zip
ast2050-yocto-poky-d2f5f2b0b129a654ae8b3ff3f048b582c93c385b.tar.gz
systemd: sed installed file instead of original
When we change the ROOT_HOME the sed regex does not match if we are running the do_install() a second time, so copy the units files first to a pre_sed, so that the next time, we can copy the the original so that the sed regex is matched correctly in the original [YOCTO #5765] (From OE-Core rev: 8a60d490755c2c3010a87f2616008aee2c9cc966) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/systemd/systemd_208.bb')
-rw-r--r--meta/recipes-core/systemd/systemd_208.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd_208.bb b/meta/recipes-core/systemd/systemd_208.bb
index 219607f..1bcedaa 100644
--- a/meta/recipes-core/systemd/systemd_208.bb
+++ b/meta/recipes-core/systemd/systemd_208.bb
@@ -89,6 +89,11 @@ EXTRA_OECONF_append_libc-uclibc = " --disable-myhostname "
do_configure_prepend() {
export CPP="${HOST_PREFIX}cpp ${TOOLCHAIN_OPTIONS} ${HOST_CC_ARCH}"
export KMOD="${base_bindir}/kmod"
+ if [ -d ${S}/units.pre_sed ] ; then
+ cp -r ${S}/units.pre_sed ${S}/units
+ else
+ cp -r ${S}/units ${S}/units.pre_sed
+ fi
sed -i -e 's:=/root:=${ROOT_HOME}:g' ${S}/units/*.service*
}
OpenPOWER on IntegriCloud