summaryrefslogtreecommitdiffstats
path: root/meta/packages/xorg-lib/libx11_git.bb
diff options
context:
space:
mode:
authorChris Larson <kergoth@openedhand.com>2006-08-15 11:58:37 +0000
committerChris Larson <kergoth@openedhand.com>2006-08-15 11:58:37 +0000
commitca10363baac7de9581ec90ab47957f973e1dbdc4 (patch)
tree2000b53f806c79510671d8fd1a6a36125f8b25b3 /meta/packages/xorg-lib/libx11_git.bb
parentc210d01a7ca8c00ddc45d292878b89086b137129 (diff)
downloadast2050-yocto-poky-ca10363baac7de9581ec90ab47957f973e1dbdc4.zip
ast2050-yocto-poky-ca10363baac7de9581ec90ab47957f973e1dbdc4.tar.gz
Numerous new xorg package versions from upstream OE. Pester me if any local changes got inadvertantly lost, or if any packages need upgrading.
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@607 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/xorg-lib/libx11_git.bb')
-rw-r--r--meta/packages/xorg-lib/libx11_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/packages/xorg-lib/libx11_git.bb b/meta/packages/xorg-lib/libx11_git.bb
new file mode 100644
index 0000000..3f7fd58
--- /dev/null
+++ b/meta/packages/xorg-lib/libx11_git.bb
@@ -0,0 +1,33 @@
+DEFAULT_PREFERENCE = "-1"
+
+DESCRIPTION = "Xlib/XCB: Xlib with XCB transport"
+SECTION = "x11/libs"
+PRIORITY = "optional"
+LICENSE = "XFree86"
+
+DEPENDS = "libxcb xproto xextproto libxau xtrans libxdmcp xcmiscproto xf86bigfontproto kbproto inputproto bigreqsproto util-macros"
+PROVIDES = "virtual/libx11"
+RPROVIDES = "virtual/libx11"
+
+FILES_${PN} += "${datadir}/X11/XKeysymDB ${datadir}/X11/XErrorDB"
+FILES_${PN}-locale += "${datadir}/X11/locale"
+
+SRC_URI = "git://anongit.freedesktop.org/git/xorg/lib/libX11;protocol=git"
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF="--enable-malloc0returnsnull"
+
+do_compile() {
+ (
+ unset CC LD CXX CCLD
+ oe_runmake -C src/util 'CC=${BUILD_CC}' 'LD=${BUILD_LD}' 'CXX=${BUILD_CXX}' 'CCLD=${BUILD_CCLD}' 'CFLAGS=-D_GNU_SOURCE ${BUILD_CFLAGS}' 'LDFLAGS=${BUILD_LDFLAGS}' 'CXXFLAGS=${BUILD_CXXFLAGS}' 'CPPFLAGS=${BUILD_CPPFLAGS}' makekeys
+ )
+ rm -f ${STAGING_INCDIR}/X11/Xlib.h
+ oe_runmake
+}
+
+do_stage() {
+ autotools_stage_all
+}
OpenPOWER on IntegriCloud