summaryrefslogtreecommitdiffstats
path: root/meta/packages/gnome
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-05-14 15:08:33 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-05-14 15:08:33 +0100
commit90208115c07a0e8c4cbffce0a846db920619c7c2 (patch)
tree2aadf31dbf5997d5c0b3883d1528d5016519a6d6 /meta/packages/gnome
parent29fb246f5e098f5630d7be5ca27cc05591e032ef (diff)
downloadast2050-yocto-poky-90208115c07a0e8c4cbffce0a846db920619c7c2.zip
ast2050-yocto-poky-90208115c07a0e8c4cbffce0a846db920619c7c2.tar.gz
gobject-introspection: Add an initial version, not functional yet
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/packages/gnome')
-rw-r--r--meta/packages/gnome/gobject-introspection/pathfix.patch53
-rw-r--r--meta/packages/gnome/gobject-introspection_git.bb20
2 files changed, 73 insertions, 0 deletions
diff --git a/meta/packages/gnome/gobject-introspection/pathfix.patch b/meta/packages/gnome/gobject-introspection/pathfix.patch
new file mode 100644
index 0000000..d640ddb
--- /dev/null
+++ b/meta/packages/gnome/gobject-introspection/pathfix.patch
@@ -0,0 +1,53 @@
+Index: git/gir/Makefile.am
+===================================================================
+--- git.orig/gir/Makefile.am 2009-05-12 14:37:40.000000000 +0100
++++ git/gir/Makefile.am 2009-05-12 14:37:40.000000000 +0100
+@@ -40,7 +40,7 @@
+ -I$(GLIB_LIBDIR)/glib-2.0/include \
+ -DGETTEXT_PACKAGE=Dummy \
+ -D__G_I18N_LIB_H__ \
+- $(GLIB_LIBDIR)/glib-2.0/include/glibconfig.h \
++ $(GLIB_INCLUDEDIR)/glibconfig.h \
+ $(srcdir)/glib-2.0.c \
+ $(GLIB_INCLUDEDIR)/glib/*.h
+ $(SCANNER) $(SCANNER_ARGS) \
+Index: git/giscanner/dumper.py
+===================================================================
+--- git.orig/giscanner/dumper.py 2009-05-12 14:37:40.000000000 +0100
++++ git/giscanner/dumper.py 2009-05-12 14:37:40.000000000 +0100
+@@ -79,7 +79,7 @@
+ self._tmpdir = tempfile.mkdtemp('', 'tmp-introspect')
+
+ self._compiler_cmd = os.environ.get('CC', 'gcc')
+- self._linker_cmd = os.environ.get('LD', self._compiler_cmd)
++ self._linker_cmd = os.environ.get('CCLD', self._compiler_cmd)
+ self._pkgconfig_cmd = os.environ.get('PKG_CONFIG', 'pkg-config')
+
+ self._uninst_srcdir = os.environ.get(
+Index: git/giscanner/scannermain.py
+===================================================================
+--- git.orig/giscanner/scannermain.py 2009-05-12 14:37:40.000000000 +0100
++++ git/giscanner/scannermain.py 2009-05-12 14:37:40.000000000 +0100
+@@ -282,6 +282,7 @@
+ shown_include_warning = False
+ for include in options.includes:
+ if os.sep in include:
++ continue
+ raise ValueError("Invalid include path %r" % (include, ))
+ include_obj = Include.from_string(include)
+ transformer.register_include(include_obj)
+Index: git/configure.ac
+===================================================================
+--- git.orig/configure.ac 2009-05-12 14:37:40.000000000 +0100
++++ git/configure.ac 2009-05-12 14:38:01.000000000 +0100
+@@ -191,7 +191,9 @@
+ esac
+ AM_CHECK_PYTHON_HEADERS(,AC_MSG_ERROR([Python headers not found]))
+
+-SHAVE_INIT([scripts])
++SHAVE_SAVED_LIBTOOL=$LIBTOOL
++AC_SUBST(SHAVE_SAVED_LIBTOOL)
++
+ AC_CONFIG_FILES([
+ Makefile
+ gir/Makefile
diff --git a/meta/packages/gnome/gobject-introspection_git.bb b/meta/packages/gnome/gobject-introspection_git.bb
new file mode 100644
index 0000000..e098044
--- /dev/null
+++ b/meta/packages/gnome/gobject-introspection_git.bb
@@ -0,0 +1,20 @@
+SRC_URI = "git://git.gnome.org/gobject-introspection;protocol=git \
+ file://pathfix.patch;patch=1"
+
+PV = "0.0+git${SRCREV}"
+PR = "r1"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "libffi python-native gobject-introspection-native"
+DEPENDS_virtclass-native = "libffi-native python-native"
+
+inherit autotools_stage
+
+TARGET_CFLAGS += "-I${STAGING_INCDIR_NATIVE}/python2.5"
+
+do_configure_prepend () {
+ echo "EXTRA_DIST = " > ${S}/gtk-doc.make
+}
+
+BBCLASSEXTEND = "native" \ No newline at end of file
OpenPOWER on IntegriCloud