summaryrefslogtreecommitdiffstats
path: root/meta/packages/abiword
diff options
context:
space:
mode:
authorTomas Frydrych <tf@openedhand.com>2007-01-12 21:26:44 +0000
committerTomas Frydrych <tf@openedhand.com>2007-01-12 21:26:44 +0000
commit2eebb483924654661dbf2429a8434d14afac55a9 (patch)
tree880e1e5e6526925a03551577470e67b76c7f7e50 /meta/packages/abiword
parent81c9ad8b0f826c1aab3ebe1eff6ccb88141bf0ad (diff)
downloadast2050-yocto-poky-2eebb483924654661dbf2429a8434d14afac55a9.zip
ast2050-yocto-poky-2eebb483924654661dbf2429a8434d14afac55a9.tar.gz
add recipes for packages needed to build AbiWord (based on OE, but tweaked for 2.5.x)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1140 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/abiword')
-rw-r--r--meta/packages/abiword/abiword.inc63
-rw-r--r--meta/packages/abiword/abiword_cvs.bb10
2 files changed, 73 insertions, 0 deletions
diff --git a/meta/packages/abiword/abiword.inc b/meta/packages/abiword/abiword.inc
new file mode 100644
index 0000000..4c2b28f
--- /dev/null
+++ b/meta/packages/abiword/abiword.inc
@@ -0,0 +1,63 @@
+DESCRIPTION = "AbiWord is free word processing program similar to Microsoft(r) Word"
+SECTION = "gnome/office"
+HOMEPAGE = "http://www.abiword.org""
+LICENSE = "GPLv2"
+
+DEPENDS = "libgsf libglade libfribidi libxml2 wv"
+RDEPENDS = "glibc-gconv-ibm850 glibc-gconv-cp1252 \
+ glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
+
+# Share this file between recipes that use cvs and that pull tarballs
+# (one day change this to differentiate automatically based on PV and set the
+# SRC_URI and S var directly)
+RELURI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz"
+RELSRC = "${WORKDIR}/abiword-${PV}/abi"
+
+CVSURI = "cvs://anoncvs:anoncvs@anoncvs.abisource.com/cvsroot;module=abi"
+CVSSRC = "${WORKDIR}/abi"
+
+#want 2.x from 2.x.y for the installation directory
+SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
+
+FILES_${PN} += " \
+ ${datadir}/icons/* \
+ ${datadir}/mime-info \
+ ${datadir}/abiword-${SHRT_VER}/glade \
+ ${datadir}/abiword-${SHRT_VER}/system.profile-en \
+ ${datadir}/abiword-${SHRT_VER}/system.profile-en-GB \
+# ${datadir}/abiword-${SHRT_VER}/templates/normal.awt \
+# ${datadir}/abiword-${SHRT_VER}/templates/normal.awt-en_GB \
+ "
+
+inherit autotools pkgconfig
+
+PARALLEL_MAKE = ""
+
+# This is a minimalistic AbiWord build
+#
+# if you are planning to build plugins, make sure to comment out the
+# --disable-exports options
+
+EXTRA_OECONF = " --enable-embedded \
+ --disable-printing \
+ --with-sys-wv \
+ --disable-exports \
+ --disable-spellcheck"
+
+# TODO -- refactor this, so that instead of two strings and profiles
+# packages we have lots of locale packages, each with a set of strings and
+# a profile
+#
+PACKAGES += " abiword-strings abiword-systemprofiles"
+
+FILES_abiword-strings += "${datadir}/abiword-${SHRT_VER}/strings"
+FILES_abiword-systemprofiles += "${datadir}/abiword-${SHRT_VER}/system.profile*"
+
+# AbiWord configure.ac does not play nicely with autoreconf
+# so use the autogen.sh script that comes with AbiWord
+#
+do_configure() {
+ cd ${S}
+ export NOCONFIGURE="no"; ./autogen.sh
+ oe_runconf
+}
diff --git a/meta/packages/abiword/abiword_cvs.bb b/meta/packages/abiword/abiword_cvs.bb
new file mode 100644
index 0000000..2c27cc2
--- /dev/null
+++ b/meta/packages/abiword/abiword_cvs.bb
@@ -0,0 +1,10 @@
+require abiword.inc
+
+SRCDATE="20070113"
+PV="2.5.0+cvs${SRCDATE}"
+PR = "r1"
+
+SRC_URI = "${CVSURI}"
+
+S = "${CVSSRC}"
+
OpenPOWER on IntegriCloud