summaryrefslogtreecommitdiffstats
path: root/meta/classes/image.bbclass
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2014-01-27 10:05:10 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-11 11:53:42 +0000
commit4d8982a1c630f88d2610a85705d68b8a0ec3c1ec (patch)
treea5db40d5386becb1cdce29ea90ab8832fb81af39 /meta/classes/image.bbclass
parentee175b5161c4d080bd5971b2e9cfafe1ba88909f (diff)
downloadast2050-yocto-poky-4d8982a1c630f88d2610a85705d68b8a0ec3c1ec.zip
ast2050-yocto-poky-4d8982a1c630f88d2610a85705d68b8a0ec3c1ec.tar.gz
image.bbclass/populate_sdk_base.bbclass: shift position of sdk complementary install definition
The sdk complementary install operation was defined in image.bbclass, but the sdk recipe (such as meta-toolchain.bb) didn't inherit this bbclass but populate_sdk, and both of image and populate_sdk bbclass inherited populate_sdk_base bbclass, so move the sdk complementary install definition to populate_sdk_base bbclass fixed this issue. (From OE-Core rev: 907458935bab391f5bfba8f581ea9835078548d9) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/image.bbclass')
-rw-r--r--meta/classes/image.bbclass19
1 files changed, 0 insertions, 19 deletions
diff --git a/meta/classes/image.bbclass b/meta/classes/image.bbclass
index e5ec42c..8f4be13 100644
--- a/meta/classes/image.bbclass
+++ b/meta/classes/image.bbclass
@@ -35,26 +35,7 @@ FEATURE_INSTALL_OPTIONAL = "${@' '.join(oe.packagegroup.optional_packages(oe.dat
SPLASH ?= "psplash"
PACKAGE_GROUP_splash = "${SPLASH}"
-# Wildcards specifying complementary packages to install for every package that has been explicitly
-# installed into the rootfs
-COMPLEMENTARY_GLOB[dev-pkgs] = '*-dev'
-COMPLEMENTARY_GLOB[staticdev-pkgs] = '*-staticdev'
-COMPLEMENTARY_GLOB[doc-pkgs] = '*-doc'
-COMPLEMENTARY_GLOB[dbg-pkgs] = '*-dbg'
-COMPLEMENTARY_GLOB[ptest-pkgs] = '*-ptest'
-
-def complementary_globs(featurevar, d):
- all_globs = d.getVarFlags('COMPLEMENTARY_GLOB')
- globs = []
- features = set((d.getVar(featurevar, True) or '').split())
- for name, glob in all_globs.items():
- if name in features:
- globs.append(glob)
- return ' '.join(globs)
-
IMAGE_INSTALL_COMPLEMENTARY = '${@complementary_globs("IMAGE_FEATURES", d)}'
-SDKIMAGE_FEATURES ??= "dev-pkgs dbg-pkgs"
-SDKIMAGE_INSTALL_COMPLEMENTARY = '${@complementary_globs("SDKIMAGE_FEATURES", d)}'
def check_image_features(d):
valid_features = (d.getVarFlag('IMAGE_FEATURES', 'validitems', True) or "").split()
OpenPOWER on IntegriCloud