summaryrefslogtreecommitdiffstats
path: root/meta/classes/cmake.bbclass
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2014-06-24 21:21:32 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-25 13:51:46 +0100
commitf3d2e32a144ae10705db8cfdb945661f04222eae (patch)
treef5e610cf0e407b52d379f95f67463f4a903e2e06 /meta/classes/cmake.bbclass
parent540b7a196a00c4dc1bf8f7c87e68e80ab310756e (diff)
downloadast2050-yocto-poky-f3d2e32a144ae10705db8cfdb945661f04222eae.zip
ast2050-yocto-poky-f3d2e32a144ae10705db8cfdb945661f04222eae.tar.gz
cmake.bbclass: restore OECMAKE_SOURCEPATH
Some packages put their CMakeLists.txt file in a subdirectory, so assuming that it is in ${S} won't work. Restore OECMAKE_SOURCEPATH (defaulting to ${S}) so that the location of CMakeLists.txt can be set if required. Based on a patch by Miroslav Keš <miroslav.kes@gmail.com> (From OE-Core rev: 2c23d7ab913a636aa0ab6a6e899cf6211d1e2714) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/classes/cmake.bbclass')
-rw-r--r--meta/classes/cmake.bbclass9
1 files changed, 6 insertions, 3 deletions
diff --git a/meta/classes/cmake.bbclass b/meta/classes/cmake.bbclass
index c9c15f3..ab2adec 100644
--- a/meta/classes/cmake.bbclass
+++ b/meta/classes/cmake.bbclass
@@ -1,3 +1,6 @@
+# Path to the CMake file to process.
+OECMAKE_SOURCEPATH ?= "${S}"
+
DEPENDS_prepend = "cmake-native "
B = "${WORKDIR}/build"
@@ -65,8 +68,8 @@ EOF
addtask generate_toolchain_file after do_patch before do_configure
cmake_do_configure() {
- if [ "${OECMAKE_BUILDPATH}" -o "${OECMAKE_SOURCEPATH}" ]; then
- bbnote "cmake.bbclass no longer uses OECMAKE_SOURCEPATH and OECMAKE_BUILDPATH. The default behaviour is now out-of-tree builds with B=WORKDIR/build."
+ if [ "${OECMAKE_BUILDPATH}" ]; then
+ bbnote "cmake.bbclass no longer uses OECMAKE_BUILDPATH. The default behaviour is now out-of-tree builds with B=WORKDIR/build."
fi
if [ "${S}" != "${B}" ]; then
@@ -84,7 +87,7 @@ cmake_do_configure() {
cmake \
${OECMAKE_SITEFILE} \
- ${S} \
+ ${OECMAKE_SOURCEPATH} \
-DCMAKE_INSTALL_PREFIX:PATH=${prefix} \
-DCMAKE_INSTALL_BINDIR:PATH=${bindir} \
-DCMAKE_INSTALL_SBINDIR:PATH=${sbindir} \
OpenPOWER on IntegriCloud