summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/ktap/ktap.inc
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-11-09 12:26:29 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-01-04 14:50:23 +0100
commit6c4cb0fb00c9b8e68ed39c87370c841deec30acf (patch)
treed64323b896cab45d097ac9bef335d9d53d9b6a40 /meta-oe/recipes-kernel/ktap/ktap.inc
parent220b31d536cf15e68c11980e0c721a7050313db1 (diff)
downloadast2050-yocto-openembedded-6c4cb0fb00c9b8e68ed39c87370c841deec30acf.zip
ast2050-yocto-openembedded-6c4cb0fb00c9b8e68ed39c87370c841deec30acf.tar.gz
ktap: add libelf PACKAGECONFIG also to ktap-module
* building ktap-module without elfutils fails with: ktap-module/0.4-r0/git/Makefile:107: No libelf found, disables symbol resolving, please install elfutils-libelf-devel/libelf-dev Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/ktap/ktap.inc')
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap.inc12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/ktap/ktap.inc b/meta-oe/recipes-kernel/ktap/ktap.inc
index 2c94a08..e2e498f 100644
--- a/meta-oe/recipes-kernel/ktap/ktap.inc
+++ b/meta-oe/recipes-kernel/ktap/ktap.inc
@@ -11,4 +11,16 @@ SRC_URI = "git://github.com/ktap/ktap.git"
S = "${WORKDIR}/git"
# Package config is abused as a general compile time configuration tool.
+
+# Only supports x86_64 for now!. Needs to be enabled for ktap-module too.
PACKAGECONFIG[ffi] = ""
+
+# Needed to resolve symbols in DSO and for sdt
+PACKAGECONFIG[libelf] = ",,elfutils"
+
+PACKAGECONFIG ?= "libelf"
+
+EXTRA_OEMAKE = " \
+ ${@base_contains('PACKAGECONFIG', 'libelf', '', 'NO_LIBELF=1', d)} \
+ ${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} \
+"
OpenPOWER on IntegriCloud