summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/nis/ypbind-mt_1.38.bb
diff options
context:
space:
mode:
authorJoe MacDonald <joe_macdonald@mentor.com>2015-02-27 09:53:51 -0500
committerJoe MacDonald <joe_macdonald@mentor.com>2015-02-27 10:31:43 -0500
commit1013f586c5a338b8be00b38056005881bef92d52 (patch)
treef177bba596b8b1fb374285c6b7849776a27f598b /meta-networking/recipes-support/nis/ypbind-mt_1.38.bb
parentd1d09c11679db18955b28b9b2cc7628b8c9223df (diff)
downloadast2050-yocto-openembedded-1013f586c5a338b8be00b38056005881bef92d52.zip
ast2050-yocto-openembedded-1013f586c5a338b8be00b38056005881bef92d52.tar.gz
nis: update yp-tools and ypbind
Both yp-tools and ypbind-mt were out of date with their latest released versions, so bump them up to current. Remove two dead patches at the same time and reorganize the recipes to better follow the preferred OE style. Finally, the new release includes a new version of the GPLv2 COPYING file, with a significant amount of whitespace fixes, so update the license checksum. Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-support/nis/ypbind-mt_1.38.bb')
-rw-r--r--meta-networking/recipes-support/nis/ypbind-mt_1.38.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/nis/ypbind-mt_1.38.bb b/meta-networking/recipes-support/nis/ypbind-mt_1.38.bb
new file mode 100644
index 0000000..f7e6b43
--- /dev/null
+++ b/meta-networking/recipes-support/nis/ypbind-mt_1.38.bb
@@ -0,0 +1,53 @@
+# This package builds the NIS ypbind daemon
+# The source package is utils/net/NIS/ypbind-mt
+#
+require nis.inc
+
+DESCRIPTION = " \
+Multithreaded NIS bind service (ypbind-mt). \
+ypbind-mt is a complete new implementation of a NIS \
+binding daemon for Linux. It has the following \
+features. Supports ypbind protocol V1 and V2. \
+Uses threads for better response. Supports multiple \
+domain bindings. Supports /var/yp/binding/* file \
+for Linux libc 4/5 and glibc 2.x. Supports a list \
+of known secure NIS server (/etc/yp.conf) Binds to \
+the server which answered as first. \
+\
+This is the final IPv4-only version of ypbind-mt. \
+"
+HOMEPAGE = "http://www.linux-nis.org/nis/ypbind-mt/index.html"
+DEPENDS = "yp-tools"
+# ypbind-mt now provides all the functionality of ypbind
+# and is used in place of it.
+PROVIDES += "ypbind"
+
+SRC_URI = "http://www.linux-nis.org/download/ypbind-mt/${BP}.tar.bz2 \
+ file://ypbind-yocto.init \
+ file://ypbind.service \
+"
+SRC_URI[md5sum] = "094088c0e282fa7f3b3dd6cc51d0a4e1"
+SRC_URI[sha256sum] = "1930ce19f6ccfe10400f3497b31867f71690d2bcd3f5b575199fa915559b7746"
+
+inherit systemd update-rc.d
+
+SYSTEMD_SERVICE_${PN} = "ypbind.service"
+INITSCRIPT_NAME = "ypbind"
+INITSCRIPT_PARAMS = "start 44 3 5 . stop 70 0 1 2 6 ."
+
+CACHED_CONFIGUREVARS = "ac_cv_prog_STRIP=/bin/true"
+
+do_install_append () {
+ install -d ${D}${sysconfdir}/init.d
+ install -d ${D}${sysconfdir}/rcS.d
+
+ install -m 0755 ${WORKDIR}/ypbind-yocto.init ${D}${sysconfdir}/init.d/ypbind
+
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/ypbind.service ${D}${systemd_unitdir}/system
+}
+
+
+RPROVIDES_${PN} += "${PN}-systemd"
+RREPLACES_${PN} += "${PN}-systemd"
+RCONFLICTS_${PN} += "${PN}-systemd"
OpenPOWER on IntegriCloud