summaryrefslogtreecommitdiffstats
path: root/meta-raptor/meta-asus/recipes-asus/fblibs/files/ipmi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'meta-raptor/meta-asus/recipes-asus/fblibs/files/ipmi/Makefile')
-rw-r--r--meta-raptor/meta-asus/recipes-asus/fblibs/files/ipmi/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-raptor/meta-asus/recipes-asus/fblibs/files/ipmi/Makefile b/meta-raptor/meta-asus/recipes-asus/fblibs/files/ipmi/Makefile
new file mode 100644
index 0000000..369819c
--- /dev/null
+++ b/meta-raptor/meta-asus/recipes-asus/fblibs/files/ipmi/Makefile
@@ -0,0 +1,27 @@
+# Copyright 2014-present Facebook. All Rights Reserved.
+#
+# This program file is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the
+# Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program in a file named COPYING; if not, write to the
+# Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301 USA
+
+lib: libipmi.so
+
+libipmi.so: ipmi.c
+ $(CC) $(CFLAGS) -fPIC -c -o ipmi.o ipmi.c
+ $(CC) -shared -o libipmi.so ipmi.o -lc
+
+.PHONY: clean
+
+clean:
+ rm -rf *.o libipmi.so
OpenPOWER on IntegriCloud