summaryrefslogtreecommitdiffstats
path: root/meta-facebook/meta-yosemite/recipes-core/images
diff options
context:
space:
mode:
Diffstat (limited to 'meta-facebook/meta-yosemite/recipes-core/images')
-rw-r--r--meta-facebook/meta-yosemite/recipes-core/images/yosemite-image.bb1
-rw-r--r--meta-facebook/meta-yosemite/recipes-core/images/yosemite-image.inc82
2 files changed, 83 insertions, 0 deletions
diff --git a/meta-facebook/meta-yosemite/recipes-core/images/yosemite-image.bb b/meta-facebook/meta-yosemite/recipes-core/images/yosemite-image.bb
new file mode 100644
index 0000000..300f167
--- /dev/null
+++ b/meta-facebook/meta-yosemite/recipes-core/images/yosemite-image.bb
@@ -0,0 +1 @@
+include yosemite-image.inc
diff --git a/meta-facebook/meta-yosemite/recipes-core/images/yosemite-image.inc b/meta-facebook/meta-yosemite/recipes-core/images/yosemite-image.inc
new file mode 100644
index 0000000..5356c20
--- /dev/null
+++ b/meta-facebook/meta-yosemite/recipes-core/images/yosemite-image.inc
@@ -0,0 +1,82 @@
+inherit aspeed_uboot_image
+
+# /dev
+require recipes-core/images/aspeed-dev.inc
+
+# Base this image on core-image-minimal
+include recipes-core/images/core-image-minimal.bb
+
+# Changing the image compression from gz to lzma achieves 30% saving (~3M).
+# However, the current u-boot does not have lzma enabled. Stick to gz
+# until we generate a new u-boot image.
+IMAGE_FSTYPES += "cpio.lzma.u-boot"
+UBOOT_IMAGE_ENTRYPOINT = "0x40800000"
+
+PYTHON_PKGS = " \
+ python-core \
+ python-io \
+ python-json \
+ python-shell \
+ python-subprocess \
+ python-argparse \
+ python-ctypes \
+ python-datetime \
+ python-email \
+ python-threading \
+ python-mime \
+ python-pickle \
+ python-misc \
+ python-netserver \
+ "
+
+NTP_PKGS = " \
+ ntp \
+ ntp-utils \
+ sntp \
+ ntpdate \
+ "
+
+# Include modules in rootfs
+IMAGE_INSTALL += " \
+ kernel-modules \
+ u-boot-fw-utils \
+ fbutils \
+ fan-ctrl \
+ watchdog-ctrl \
+ i2c-tools \
+ sensor-setup \
+ usb-console \
+ lmsensors-sensors \
+ rest-api \
+ bottle \
+ ipmid \
+ ${PYTHON_PKGS} \
+ ${NTP_PKGS} \
+ iproute2 \
+ dhcp-client \
+ fruid \
+ ipmbd \
+ bic-cached \
+ bic-util \
+ yosemite-sensors \
+ sensor-util \
+ sensor-mon \
+ gpiod \
+ front-paneld \
+ power-util \
+ consoled \
+ cfg-util \
+ "
+
+IMAGE_FEATURES += " \
+ ssh-server-openssh \
+ tools-debug \
+ "
+
+DISTRO_FEATURES += " \
+ ext2 \
+ ipv6 \
+ nfs \
+ usbgadget \
+ usbhost \
+ "
OpenPOWER on IntegriCloud