summaryrefslogtreecommitdiffstats
path: root/meta-facebook/meta-wedge/recipes-core/init-ifupdown
diff options
context:
space:
mode:
Diffstat (limited to 'meta-facebook/meta-wedge/recipes-core/init-ifupdown')
-rw-r--r--meta-facebook/meta-wedge/recipes-core/init-ifupdown/files/dhcpv6_down27
-rw-r--r--meta-facebook/meta-wedge/recipes-core/init-ifupdown/files/dhcpv6_up28
-rw-r--r--meta-facebook/meta-wedge/recipes-core/init-ifupdown/init-ifupdown_%.bbappend16
3 files changed, 0 insertions, 71 deletions
diff --git a/meta-facebook/meta-wedge/recipes-core/init-ifupdown/files/dhcpv6_down b/meta-facebook/meta-wedge/recipes-core/init-ifupdown/files/dhcpv6_down
deleted file mode 100644
index a44deb4..0000000
--- a/meta-facebook/meta-wedge/recipes-core/init-ifupdown/files/dhcpv6_down
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/bin/bash
-#
-# Copyright 2015-present Facebook. All Rights Reserved.
-#
-# This program file is free software; you can redistribute it and/or modify it
-# under the terms of the GNU General Public License as published by the
-# Free Software Foundation; version 2 of the License.
-#
-# This program is distributed in the hope that it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
-# for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program in a file named COPYING; if not, write to the
-# Free Software Foundation, Inc.,
-# 51 Franklin Street, Fifth Floor,
-# Boston, MA 02110-1301 USA
-#
-
-pid="/var/run/dhclient6.${IFACE}.pid"
-
-if [ -f "${pid}" ]; then
- kill -9 `cat ${pid}` 2>/dev/null
-fi
-
-exit 0
diff --git a/meta-facebook/meta-wedge/recipes-core/init-ifupdown/files/dhcpv6_up b/meta-facebook/meta-wedge/recipes-core/init-ifupdown/files/dhcpv6_up
deleted file mode 100644
index 6469b9f..0000000
--- a/meta-facebook/meta-wedge/recipes-core/init-ifupdown/files/dhcpv6_up
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/bin/bash
-#
-# Copyright 2015-present Facebook. All Rights Reserved.
-#
-# This program file is free software; you can redistribute it and/or modify it
-# under the terms of the GNU General Public License as published by the
-# Free Software Foundation; version 2 of the License.
-#
-# This program is distributed in the hope that it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
-# for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program in a file named COPYING; if not, write to the
-# Free Software Foundation, Inc.,
-# 51 Franklin Street, Fifth Floor,
-# Boston, MA 02110-1301 USA
-#
-
-# only care about 'eth0' and 'oob' intf
-[ "$IFACE" != "eth0" ] && [ "$IFACE" != "oob" ] && exit 0
-
-pid="/var/run/dhclient6.${IFACE}.pid"
-
-dhclient -6 -nw -pf ${pid} ${IFACE}
-
-exit 0
diff --git a/meta-facebook/meta-wedge/recipes-core/init-ifupdown/init-ifupdown_%.bbappend b/meta-facebook/meta-wedge/recipes-core/init-ifupdown/init-ifupdown_%.bbappend
index e715c27..7d74521 100644
--- a/meta-facebook/meta-wedge/recipes-core/init-ifupdown/init-ifupdown_%.bbappend
+++ b/meta-facebook/meta-wedge/recipes-core/init-ifupdown/init-ifupdown_%.bbappend
@@ -1,18 +1,2 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-
-SRC_URI += "file://dhcpv6_up \
- file://dhcpv6_down \
- "
-
-do_install_append() {
- # rules to request dhcpv6
- install -d ${D}/${sysconfdir}/network/if-up.d
- install -m 755 ${WORKDIR}/dhcpv6_up ${D}${sysconfdir}/network/if-up.d/dhcpv6_up
- install -d ${D}/${sysconfdir}/network/if-down.d
- install -m 755 ${WORKDIR}/dhcpv6_down ${D}${sysconfdir}/network/if-down.d/dhcpv6_down
-}
-
-FILES_${PN} += "${sysconfdir}/network/if-up.d/dhcpv6_up \
- ${sysconfdir}/network/if-down.d/dhcpv6_down \
- "
OpenPOWER on IntegriCloud