summaryrefslogtreecommitdiffstats
path: root/common/recipes-rest/rest-api/rest-api_0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-rest/rest-api/rest-api_0.2.bb')
-rw-r--r--common/recipes-rest/rest-api/rest-api_0.2.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/common/recipes-rest/rest-api/rest-api_0.2.bb b/common/recipes-rest/rest-api/rest-api_0.2.bb
new file mode 100644
index 0000000..1956cb2
--- /dev/null
+++ b/common/recipes-rest/rest-api/rest-api_0.2.bb
@@ -0,0 +1,36 @@
+# Copyright 2015-present Facebook. All Rights Reserved.
+#
+# This program file is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the
+# Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program in a file named COPYING; if not, write to the
+# Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301 USA
+SUMMARY = "Rest API Daemon"
+DESCRIPTION = "Daemon to handle RESTful interface."
+SECTION = "base"
+PR = "r1"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://rest.py;beginline=5;endline=18;md5=0b1ee7d6f844d472fa306b2fee2167e0"
+
+
+SRC_URI = "file://rest.py \
+ file://node.py \
+ file://tree.py \
+ file://pal.py \
+ "
+DEPENDS += "libpal"
+
+
+binfiles = "rest.py node.py tree.py pal.py"
+
+pkgdir = "rest-api"
+RDEPENDS_${PN} += "libpal"
OpenPOWER on IntegriCloud