summaryrefslogtreecommitdiffstats
path: root/common/recipes-core/power-util/power-util_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-core/power-util/power-util_0.1.bb')
-rw-r--r--common/recipes-core/power-util/power-util_0.1.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/common/recipes-core/power-util/power-util_0.1.bb b/common/recipes-core/power-util/power-util_0.1.bb
new file mode 100644
index 0000000..69ef2ad
--- /dev/null
+++ b/common/recipes-core/power-util/power-util_0.1.bb
@@ -0,0 +1,36 @@
+# Copyright 2015-present Facebook. All Rights Reserved.
+SUMMARY = "Power Utility"
+DESCRIPTION = "Utility for Power Policy and Management"
+SECTION = "base"
+PR = "r1"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://power-util.c;beginline=4;endline=16;md5=b395943ba8a0717a83e62ca123a8d238"
+
+SRC_URI = "file://Makefile \
+ file://power-util.c \
+ "
+S = "${WORKDIR}"
+
+LDFLAGS =+ " -lpal "
+
+DEPENDS =+ " libpal "
+
+binfiles = "power-util"
+
+pkgdir = "power-util"
+
+do_install() {
+ dst="${D}/usr/local/fbpackages/${pkgdir}"
+ bin="${D}/usr/local/bin"
+ install -d $dst
+ install -d $bin
+ install -m 755 power-util ${dst}/power-util
+ ln -snf ../fbpackages/${pkgdir}/power-util ${bin}/power-util
+}
+
+FBPACKAGEDIR = "${prefix}/local/fbpackages"
+
+FILES_${PN} = "${FBPACKAGEDIR}/power-util ${prefix}/local/bin"
+
+INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
+INHIBIT_PACKAGE_STRIP = "1"
OpenPOWER on IntegriCloud