summaryrefslogtreecommitdiffstats
path: root/common/recipes-core/healthd/healthd_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'common/recipes-core/healthd/healthd_0.1.bb')
-rw-r--r--common/recipes-core/healthd/healthd_0.1.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/common/recipes-core/healthd/healthd_0.1.bb b/common/recipes-core/healthd/healthd_0.1.bb
new file mode 100644
index 0000000..0c4b2e9
--- /dev/null
+++ b/common/recipes-core/healthd/healthd_0.1.bb
@@ -0,0 +1,42 @@
+# Copyright 2015-present Facebook. All Rights Reserved.
+SUMMARY = "Health Monitoring Daemon"
+DESCRIPTION = "Daemon for BMC Health monitoring"
+SECTION = "base"
+PR = "r1"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://healthd.c;beginline=4;endline=16;md5=b395943ba8a0717a83e62ca123a8d238"
+
+SRC_URI = "file://Makefile \
+ file://healthd.c \
+ file://setup-healthd.sh \
+ "
+S = "${WORKDIR}"
+
+LDFLAGS =+ " -lpal "
+
+DEPENDS =+ " libpal "
+
+binfiles = "healthd"
+
+pkgdir = "healthd"
+
+do_install() {
+ dst="${D}/usr/local/fbpackages/${pkgdir}"
+ bin="${D}/usr/local/bin"
+ install -d $dst
+ install -d $bin
+ install -m 755 healthd ${dst}/healthd
+ ln -snf ../fbpackages/${pkgdir}/healthd ${bin}/healthd
+
+ install -d ${D}${sysconfdir}/init.d
+ install -d ${D}${sysconfdir}/rcS.d
+ install -m 755 setup-healthd.sh ${D}${sysconfdir}/init.d/setup-healthd.sh
+ update-rc.d -r ${D} setup-healthd.sh start 91 5 .
+}
+
+FBPACKAGEDIR = "${prefix}/local/fbpackages"
+
+FILES_${PN} = "${FBPACKAGEDIR}/healthd ${prefix}/local/bin ${sysconfdir} "
+
+INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
+INHIBIT_PACKAGE_STRIP = "1"
OpenPOWER on IntegriCloud