summaryrefslogtreecommitdiffstats
path: root/meta-facebook/meta-wedge/recipes-core
diff options
context:
space:
mode:
authorOri Bernstein <orib@fb.com>2015-09-03 13:06:18 -0700
committerOri Bernstein <orib@fb.com>2015-09-23 18:10:45 -0700
commit67f44805b41a532b7b440773f7ee6d17dc0e97f4 (patch)
treec21a66b12c4d92a765e1ee0d47b96e2a2b9cd0d2 /meta-facebook/meta-wedge/recipes-core
parent2a51b7c1c2165ddb188c511e192b75f0aa0fbead (diff)
downloadast2050-yocto-openbmc-67f44805b41a532b7b440773f7ee6d17dc0e97f4.zip
ast2050-yocto-openbmc-67f44805b41a532b7b440773f7ee6d17dc0e97f4.tar.gz
Openbmc dev snapshot.
Diffstat (limited to 'meta-facebook/meta-wedge/recipes-core')
-rw-r--r--meta-facebook/meta-wedge/recipes-core/images/wedge-image.inc6
-rw-r--r--meta-facebook/meta-wedge/recipes-core/init-ifupdown/files/dhcpv6_down27
-rw-r--r--meta-facebook/meta-wedge/recipes-core/init-ifupdown/files/dhcpv6_up28
-rw-r--r--meta-facebook/meta-wedge/recipes-core/init-ifupdown/init-ifupdown_%.bbappend16
4 files changed, 75 insertions, 2 deletions
diff --git a/meta-facebook/meta-wedge/recipes-core/images/wedge-image.inc b/meta-facebook/meta-wedge/recipes-core/images/wedge-image.inc
index 15a4252..7cd89de 100644
--- a/meta-facebook/meta-wedge/recipes-core/images/wedge-image.inc
+++ b/meta-facebook/meta-wedge/recipes-core/images/wedge-image.inc
@@ -39,9 +39,8 @@ NTP_PKGS = " \
# Include modules in rootfs
IMAGE_INSTALL += " \
kernel-modules \
- u-boot \
u-boot-fw-utils \
- fbutils \
+ openbmc-utils \
fan-ctrl \
rackmon \
watchdog-ctrl \
@@ -49,6 +48,8 @@ IMAGE_INSTALL += " \
sensor-setup \
usb-console \
oob-nic \
+ lldp-util \
+ bmc-log \
lmsensors-sensors \
wedge-eeprom \
sms-kcsd \
@@ -61,6 +62,7 @@ IMAGE_INSTALL += " \
${NTP_PKGS} \
iproute2 \
dhcp-client \
+ spatula \
"
IMAGE_FEATURES += " \
diff --git a/meta-facebook/meta-wedge/recipes-core/init-ifupdown/files/dhcpv6_down b/meta-facebook/meta-wedge/recipes-core/init-ifupdown/files/dhcpv6_down
new file mode 100644
index 0000000..a44deb4
--- /dev/null
+++ b/meta-facebook/meta-wedge/recipes-core/init-ifupdown/files/dhcpv6_down
@@ -0,0 +1,27 @@
+#!/bin/bash
+#
+# Copyright 2015-present Facebook. All Rights Reserved.
+#
+# This program file is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the
+# Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program in a file named COPYING; if not, write to the
+# Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301 USA
+#
+
+pid="/var/run/dhclient6.${IFACE}.pid"
+
+if [ -f "${pid}" ]; then
+ kill -9 `cat ${pid}` 2>/dev/null
+fi
+
+exit 0
diff --git a/meta-facebook/meta-wedge/recipes-core/init-ifupdown/files/dhcpv6_up b/meta-facebook/meta-wedge/recipes-core/init-ifupdown/files/dhcpv6_up
new file mode 100644
index 0000000..6469b9f
--- /dev/null
+++ b/meta-facebook/meta-wedge/recipes-core/init-ifupdown/files/dhcpv6_up
@@ -0,0 +1,28 @@
+#!/bin/bash
+#
+# Copyright 2015-present Facebook. All Rights Reserved.
+#
+# This program file is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the
+# Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program in a file named COPYING; if not, write to the
+# Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301 USA
+#
+
+# only care about 'eth0' and 'oob' intf
+[ "$IFACE" != "eth0" ] && [ "$IFACE" != "oob" ] && exit 0
+
+pid="/var/run/dhclient6.${IFACE}.pid"
+
+dhclient -6 -nw -pf ${pid} ${IFACE}
+
+exit 0
diff --git a/meta-facebook/meta-wedge/recipes-core/init-ifupdown/init-ifupdown_%.bbappend b/meta-facebook/meta-wedge/recipes-core/init-ifupdown/init-ifupdown_%.bbappend
index 7d74521..e715c27 100644
--- a/meta-facebook/meta-wedge/recipes-core/init-ifupdown/init-ifupdown_%.bbappend
+++ b/meta-facebook/meta-wedge/recipes-core/init-ifupdown/init-ifupdown_%.bbappend
@@ -1,2 +1,18 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI += "file://dhcpv6_up \
+ file://dhcpv6_down \
+ "
+
+do_install_append() {
+ # rules to request dhcpv6
+ install -d ${D}/${sysconfdir}/network/if-up.d
+ install -m 755 ${WORKDIR}/dhcpv6_up ${D}${sysconfdir}/network/if-up.d/dhcpv6_up
+ install -d ${D}/${sysconfdir}/network/if-down.d
+ install -m 755 ${WORKDIR}/dhcpv6_down ${D}${sysconfdir}/network/if-down.d/dhcpv6_down
+}
+
+FILES_${PN} += "${sysconfdir}/network/if-up.d/dhcpv6_up \
+ ${sysconfdir}/network/if-down.d/dhcpv6_down \
+ "
OpenPOWER on IntegriCloud