summaryrefslogtreecommitdiffstats
path: root/common/recipes-utils/openbmc-gpio/files/setup.py
diff options
context:
space:
mode:
authorOri Bernstein <orib@fb.com>2015-09-03 13:06:18 -0700
committerOri Bernstein <orib@fb.com>2015-09-23 18:10:45 -0700
commit67f44805b41a532b7b440773f7ee6d17dc0e97f4 (patch)
treec21a66b12c4d92a765e1ee0d47b96e2a2b9cd0d2 /common/recipes-utils/openbmc-gpio/files/setup.py
parent2a51b7c1c2165ddb188c511e192b75f0aa0fbead (diff)
downloadast2050-yocto-openbmc-67f44805b41a532b7b440773f7ee6d17dc0e97f4.zip
ast2050-yocto-openbmc-67f44805b41a532b7b440773f7ee6d17dc0e97f4.tar.gz
Openbmc dev snapshot.
Diffstat (limited to 'common/recipes-utils/openbmc-gpio/files/setup.py')
-rw-r--r--common/recipes-utils/openbmc-gpio/files/setup.py36
1 files changed, 36 insertions, 0 deletions
diff --git a/common/recipes-utils/openbmc-gpio/files/setup.py b/common/recipes-utils/openbmc-gpio/files/setup.py
new file mode 100644
index 0000000..59c7de4
--- /dev/null
+++ b/common/recipes-utils/openbmc-gpio/files/setup.py
@@ -0,0 +1,36 @@
+#!/usr/bin/env python
+# Copyright 2015-present Facebook. All Rights Reserved.
+#
+# This program file is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the
+# Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program in a file named COPYING; if not, write to the
+# Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor,
+# Boston, MA 02110-1301 USA
+
+
+from distutils.core import setup
+
+setup(
+ name = 'openbmc-gpio',
+ version = '1.0',
+ description = 'OpenBMC GPIO utilities',
+ author = 'Tian Fang',
+ author_email = 'tfang@fb.com',
+ license = 'GPLv2',
+ py_modules=['openbmc_gpio',
+ 'openbmc_gpio_table',
+ 'phymemory',
+ 'soc_gpio',
+ 'soc_gpio_table',
+ 'board_gpio_table',
+ ],
+)
OpenPOWER on IntegriCloud