summaryrefslogtreecommitdiffstats
path: root/tools/c-index-test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/c-index-test/CMakeLists.txt')
-rw-r--r--tools/c-index-test/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/tools/c-index-test/CMakeLists.txt b/tools/c-index-test/CMakeLists.txt
index d0872fd..c78a42f 100644
--- a/tools/c-index-test/CMakeLists.txt
+++ b/tools/c-index-test/CMakeLists.txt
@@ -28,3 +28,23 @@ if (CLANG_HAVE_LIBXML)
include_directories(SYSTEM ${LIBXML2_INCLUDE_DIR})
target_link_libraries(c-index-test ${LIBXML2_LIBRARIES})
endif()
+
+if (NOT LLVM_INSTALL_TOOLCHAIN_ONLY)
+ if(INTERNAL_INSTALL_PREFIX)
+ set(INSTALL_DESTINATION "${INTERNAL_INSTALL_PREFIX}/bin")
+ else()
+ set(INSTALL_DESTINATION bin)
+ endif()
+
+ install(TARGETS c-index-test
+ RUNTIME DESTINATION "${INSTALL_DESTINATION}"
+ COMPONENT c-index-test)
+
+ if (NOT CMAKE_CONFIGURATION_TYPES) # don't add this for IDE's.
+ add_custom_target(install-c-index-test
+ DEPENDS c-index-test
+ COMMAND "${CMAKE_COMMAND}"
+ -DCMAKE_INSTALL_COMPONENT=c-index-test
+ -P "${CMAKE_BINARY_DIR}/cmake_install.cmake")
+ endif()
+endif()
OpenPOWER on IntegriCloud